1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Brakes....

Discussion in 'General Tech and Maintenance' started by 1995EGGuy, Sep 2, 2006.

  1. 1995EGGuy

    1995EGGuy Senior Member

    Messages:
    183
    Likes Received:
    0
    Joined:
    May 29, 2005
    Location:
    New Jersey
    When I had my stock rotors and brake pads on the brake pedal was fine. When I put my crossed-drilled and slotted rotors with satisfied gransport brake pads on..when i start the car the pedal goes so low and i bled all four brakes really good. The rotors and pads only have like 6000 miles on them. I tried a master cylinder and its not that so thats ruled out. im thinking its the two calipers lemme know what you guys think.
     
  2. 92CHB

    92CHB Senior Member

    Messages:
    707
    Likes Received:
    0
    Joined:
    Mar 23, 2004
    Location:
    Easthampton, MA
    I'd try re bleeding the brakes to make sure and also try replacing the valve thats in the vacuum line that goes to your intake manifold.
     
  3. 1995EGGuy

    1995EGGuy Senior Member

    Messages:
    183
    Likes Received:
    0
    Joined:
    May 29, 2005
    Location:
    New Jersey
    What is that valve called?
     
  4. 92CHB

    92CHB Senior Member

    Messages:
    707
    Likes Received:
    0
    Joined:
    Mar 23, 2004
    Location:
    Easthampton, MA
    Its a check valve, its right behind the cap of your master cylinder
     
Verification:
Draft saved Draft deleted

Share This Page