1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help A.S.A.P

Discussion in 'General Tech and Maintenance' started by TeamUrbanChaos, May 25, 2006.

  1. TeamUrbanChaos

    TeamUrbanChaos Certified H22 Super-tech

    Likes Received:
    Jan 20, 2004
    Home Of ThE LoSt Towers
    6 months ago i helped my friend complete his H22 swap in his accord. its been working fine since then. the car has sat for the past 2 months becuase he's in college and keeps the car garaged. about 2 weeks ago he went to fire it up and there was a repeated backfiring in the intake manifold. it got to the point where it backfired so bad it blew some flames out of the intake itself. i thought the motor was blown but it stated up after that but it kept having mild backfires.

    i thought maybe one of his injectors were bad so i replaced them with 4 h22 injectors i had but the problem still exist and it seems even worse!!!

    tomorrow im going to change the spark plugs but to be honest with you i really dont know if thats going to help or not. i cant imagine whats going on. it was just 2 months ago we were crusing and the car was just fine and its been garaged since then now out of nowhere after sitting for a couple months it does this??? dosent make any sense...someone please help me out!! [​IMG] [​IMG] [​IMG]
  2. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Likes Received:
    Apr 27, 2005
    San Antonio, TX
    sounds like an exhaust valve isnt opening, but i couldnt imagine how one would pull that off.
Draft saved Draft deleted

Share This Page