1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help ASAP!!!

Discussion in 'Other Vehicle Discussions' started by K2e2vin, Feb 28, 2006.

  1. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    Well let me begin; on Monday/yesterday I noticed the heat started getting cooler; didnt think much of it. Today, I noticed the engine temp was higher than before; ok i need to replace thermostat.

    Later on, my mom was driving it(I only drive it to work; my mom takes it back and I get a ride from a friend when I get off) and the car overheated like hell. I completely took out the thermostat thinking the old thermostat was just sticking close; nope! Car still overheated and the heater was cold(fluid was still full).

    I changed the thermostat and flushed the radiator; ran it and noticed the fans werent coming on even though the thermostat was open. The fan has two motors; both run off of two relays(a high and lo relay), and the fuse was still good. I searched for radiator fans for the car and noticed they sell just the motors for it; two. Problem is, none of the fans came on. Do you think its some wiring issue or somehow both of the motors died at the same time? btw, a complete fan assembly costs $300(this will prevent me from getting my intake runners made...).

    I can't use the CRXs because one; the front is just fucked(no headlights, intake manifold, throttle, etc. gone, etc. etc.) and the other CRX is without a transmission(god damn bolt broke with only 21lb-tq...) and rear trailing arms gone.


    cliffs: Found out radiator fan is not coming on; hi and lo rad. fan relays look good, fuse is still good. What's going on????
     
  2. kaoskustoms

    kaoskustoms Senior Member

    Messages:
    550
    Likes Received:
    0
    Joined:
    Jan 6, 2003
    Location:
    casper wyoming man
    check conetor plug in they are bad about burning the contacts on the harnees and on the plug in it self


    warm up car to normal opperating temp and check to see if you have power at the plug
     
  3. Celerity

    Celerity Well-Known Member

    Messages:
    21,969
    Likes Received:
    146
    Joined:
    Sep 11, 2003
    Avoid this car like the fucking plague.

    Sell it, trade it, do whatever you can do. Run away from it.
     
  4. hosmer

    hosmer I made the millionth post VIP

    Messages:
    3,162
    Likes Received:
    82
    Joined:
    Jan 26, 2005
    Location:
    B R I D G E W A T E R
    Check the junkyards...I'm assuming its a 93-97

    You should be able to get the whole assembly for $50 (we have 3 and thats what we sell them for)


    Cars with the same setup:
    93-97 Concorde, LHS, Vision, Intrepid, & New Yorker
     
  5. ScrapinSi

    ScrapinSi Senior Member

    Messages:
    3,292
    Likes Received:
    4
    Joined:
    Feb 27, 2003
    The Concordes are INFAMOUS for relay problems, as well as fan assemblies going bad. I would look at the relays first... Or the temp switches...

    Also... On most cars the 2nd fan is for the a/c... turn on the a/c and see if the 2nd fan kicks on.
     
  6. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    I finally got it fixed. I still don't know why the radiator fan didn't come on at that time, but it works fine. I'll change out the relays just to be on the safe side. The overheating was cause mainly from a hole in the reservoir and both of the radiator caps werent holding pressure.
     
Verification:
Draft saved Draft deleted

Share This Page