1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NEED HELP. pistons or valves?

Discussion in 'General Tech and Maintenance' started by HatchGSR-T, Dec 18, 2007.

  1. HatchGSR-T

    HatchGSR-T New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Dec 18, 2007
    Location:
    colorado springs
    alright heres whats wrong
    when i start the car sounds great. smokes quite a bit.
    i jus replaced my valve cover gasket and a broken stud which leaked oil ontop of the valve cover because i thought a blew the gasket because of the excessive oil leak from the valve cover gasket an excessive smoke from exhaust, I parked it right away. Now after i fixed it, It now spits oil from the breather filter i have and smokes alot still an now its bogging an feels like theres a clog somewhere when I rev it, even if its jus to 2 or 3 thousand rpm's, and jus noticed that the valve seal stems under the cover are slightly scrathcing the sides of the walls. So im thinking its either my piston rings or valve seals (all 16) that are damaged. I dont know whats really goin on, please help? Thanks.
     
  2. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    what car?what motor?what color smoke??
     
  3. HatchGSR-T

    HatchGSR-T New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Dec 18, 2007
    Location:
    colorado springs
    92 hatch b18c1 white(lots)
    and a t3/t4 turbo
     
Verification:
Draft saved Draft deleted

Share This Page