1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help quick...

Discussion in 'General Tech and Maintenance' started by ChrisSiR, Jan 7, 2004.

  1. ChrisSiR

    ChrisSiR Senior Member

    Messages:
    259
    Likes Received:
    0
    Joined:
    Apr 22, 2003
    Im having problems getting ahold of a water pump for my b16a.... i ordered up a pump for a 99si (belt too) but the pump i pulled of and the pump for the Si are completely different, SO... i ordered up a pump for a 90 LS (onlything that doesnt match is the sprocket) and picked up the LS belt as well..... is this going to work? w/ the shorter belt?.... or should i just try and find another pump (95 del sol si, is a perfect match), only problem is i have to order it and it will take a few days to get shipped....


    Any info would be great!!!
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    the ls pump is different i belive... dont' use that.

    i don't have a b16a, so i can't help you any more there though... but i would think that the b16a3 del sol VTEC (NOT the Si...) pump should work fine.
     
  3. slick*vic*

    slick*vic* Member

    Messages:
    96
    Likes Received:
    0
    Joined:
    Oct 30, 2003
    the del sol v-tec and the 99 si are the same. i have a sir-II and replaced it with a 99 si. compared the one out of the del sol with the one that came out of the sir-II it was the exact same pump. i dont know which one you need. probably for the
    sir-I
     
Verification:
Draft saved Draft deleted

Share This Page