1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help with b16a swap

Discussion in 'HYBRID -> ED-EF / DA' started by JAKracing, Apr 13, 2008.

  1. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    i have a 90 hatch std.. i just swapped in a jdm b16a, i used my stock harness and did the DPFI to MPFI conversion, also wired the vtec. now when i turn the key my fuel pump doesn't come on, and the check engine light don't come on. no codes from the ecu????? can anyone help
     
  2. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    is anything working?
    what ecu are you using?
     
  3. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    using PW0 ecu, before i did the MPFI conversion, i was using the b16 harness. well everything worked except the dizzy. fuel pump was coming on, check engine light was on, and the ecu was showing codes. since the conversion, nothing works. i have checked and rechecked all the wiring and it all seems to be right. so i am stuck now
     
  4. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs
    do you have the ground wires connected at the thermostat housing? these are the grounds for the ECU and most of the sensors
     

    Attached Files:

  5. efhondakid

    efhondakid My name is Byron. VIP

    Messages:
    7,034
    Likes Received:
    202
    Joined:
    Mar 2, 2007
    Location:
    Akron-Canton, Ohio
    If you dont have fuel pump or a check engine light with key on you dont have any power to the ECU. Check all your fuses too, and the main relay right up by the hood release, it has eight pins in it. You can pull the cover off and make sure none of the solder is melted, it happened with both my EF and EG.
     
  6. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    do you get power to anything? ie: radio, headlights, etc...
     
  7. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    yeah radio, headlights, cluster lights. all those work
     
  8. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    i'd go with a ground, but i beleive your dash lights would still come on, as well as your pump. it just wouldn't start.
    so, i'm gonna go with fuse or main relay, or the ecu(sounds promising). how long did the car sit?
    i'm no expert, but those are my oppinions.
     
  9. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    the car has been sitting for about 2 months
     
  10. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    this has been a long process, that was only surpose to last about 3-4 days
     
  11. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    can someone tell me where the other end of this ground goes?? i don't get much time to work on my car and when i do it ain't enough to be worth it. so i need to know this so i can go outside and get it done
     
  12. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    to your harness. if you're not using the right harness, i'm not sure where it is supposed to end up at.
     
  13. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    WELL I GOT IT RUNNING TODAY!!!!!!!!!!!!!!!! thanx for all the help guys
     
  14. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    :confused:and the problem was.....
     
  15. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    a damn ground wire that grounds the ecu and the main fuel relay
     
  16. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    well i need somemore help. the car is running fine except for the alignment and i am throwing a code 17(VSS). what do i need to get that working? the motor came with a electrical one, but i have a cable driven speedo. so what do i need to get?
     
  17. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
  18. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
  19. JAKracing

    JAKracing New Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 13, 2008
    Location:
    rocky mount, nc
    thanx man. someone just told me the same thing on another site. but thanx for the help....its really appreciated
     
Verification:
Draft saved Draft deleted

Share This Page