1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help with tps

Discussion in 'HYBRID -> EG-EK / DC' started by civic-style, Apr 14, 2004.

  1. civic-style

    civic-style Junior Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Jul 11, 2003
    I have a 95 civic dx with a sir-II swapped in it. I'm using a p30 ecu. When im driving and try to accelerate quickly it feels like my engine starts to misfire very bad to the point where the car jerks. I have only code 7 shown which is the tps. I changed it but still it does the same thing. Also when it does start to jerk the CEL will turn off and then when it stops the CEL turns back on. Any help would be nice.
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    its probably not wired up right...

    also, check the knock sensor
     
  3. Projectzc

    Projectzc Senior Member

    Messages:
    103
    Likes Received:
    0
    Joined:
    Oct 3, 2003
    Yeah that sounds like a dead spot in the Tps. Or it is not wired correctly. There is some adjustablity to the TPS see if advanceing it or retarding it helps.
     
  4. sleepercivic

    sleepercivic Senior Member

    Messages:
    227
    Likes Received:
    1
    Joined:
    Mar 14, 2003
    Location:
    NC Mountains
    check your voltage it needs to be .5 closed and 4.5 wot, i believe
     
Verification:
Draft saved Draft deleted

Share This Page