1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need some help with LS engine

Discussion in 'General Tech and Maintenance' started by Ecky, Oct 31, 2011.

  1. Ecky

    Ecky New Member

    Likes Received:
    Oct 31, 2011
    I killed the B16 in my Del Sol, and swapped a B18A1 in (got it dirt cheap). I converted it to OBD1 using the B16's dizzy, a B18B intake manifold, and B16A throttle body. I've been tinkering with it but I'm not the most knowledgeable backyard mechanic, and I have a few issues I'm still trying to iron out.

    When I put it together I wasn't thinking about the timing and just put the distributor on at the angle that gave the most power. I've been trying to figure out why I had a high idle, and earlier today I realized the advanced timing was probably contributing to it. Is the distributor adjustable from what, 0° to 30°? I've been driving it around for several weeks advanced all the way and I haven't heard any knocks... is it ok at 30° if I'm not hearing any pinging? The engine feels pretty lame at the stock 16° after driving around with advanced timing.

    My radiator fan wasn't coming on and I had to rewire it to turn on when I turn the key. I looked for the sensor or switch I thought was supposed to be on the thermostat, and found there wasn't one. I have a connector dangling on my engine harness... what should I do here? Maybe it's located in a different spot on OBD0 engines?

    My engine has also been using a little bit of oil. I haven't seen any smoke, but it's using maybe half a quart every thousand miles. I drive it a little hard... could the oil usage be related to the advanced timing? I developed some valve tapping and have been thinking of adjusting them, but a buddy of mine suggested that I might have messed up one of the valve stem seals and that's why it's tapping and using oil. I was told to roll down a hill in low gear and gun it at the bottom, and watch for smoke, but I saw none. Where is the oil going!?

    I have a set of B18B cams, are there any good guides to swapping the cams out in these motors? What are the clearances I'm supposed to use with the B cams, the B18B's or the A1's?

    Lastly, my tachometer is majorly messed up. It reads fine below 2k rpm, but once I start to rev up, it bounces around like crazy. How is the tach wired? What should I look for to fix this?

    Thanks all!
  2. jlicrx

    jlicrx Senior Member

    Likes Received:
    Jun 5, 2003
    Colorado Springs
    on the OBD0 B18, the cooling fan switch is on the back of the block next to the oil filter - you will need to swap the connector

  3. Dj211855

    Dj211855 New Member

    Likes Received:
    Aug 2, 2011
    30* huh!!!!!!!!!!!!!!!!!!!!!!


    stock timing at 16*.

    CAFROG Honda Minion VIP

    Likes Received:
    Apr 5, 2009
    Use a timing gun and go off the marks on the crank pulley. What you think is 30 degrees and or 16 degrees may not be what the crank expresses.
Draft saved Draft deleted

Share This Page