1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New High CR built Z6 is slow...

Discussion in 'Engine Building' started by Utrax42, Jun 7, 2009.

  1. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    :confused: Brand new build, I finished the install today.
    The Compression Ratio is about 10.8:1 adjusted to my altitude (4200ft). got that from autowerks.
    Build:
    D16Z6(w/ tranny) bored .020+ and block decked .003"
    +.020" PG6B pistons
    11lb flywheel
    D15B7 Intake Manifold
    CAI
    All Stock exhaust (how much would this kill me?)
    running 91 octane
    modified D15B7 distributor, but still can't get my ignition timing right. its at 14btdc
    Cam Gear set at 2deg Advanced.
    Running a custom Xenocron chip.

    No CEL's except when I get on it in higher rpms, but no code shows. Is that the knock sensor? It does not feel like vtec is working, should I feel it?

    This setup is as slow as if not slower than the D15B7 that was in it that had 163k on it.

    Any advice please?
     
  2. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    And I'm running a number 6 NGK plug.

    As I would get on the throttle the temperature gauge would drop and pop back up when I let off the throttle.

    Additional problem...
    I added 1 bottle octane booster. Car still ran like crap. I then switched to my old spoon chip, and it ran the same. But then as I was on it again, the speedo started jumping around and the car suddenly fell on its face. ran terrible and died. I've gotten it to start for like one second total then it dies. I tried the custom chip again and no change. Obviousely this is electrical, which I have No experience in. Again, any ideas? Thanks
     
  3. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,456
    Likes Received:
    2,117
    Joined:
    Nov 18, 2007
    Location:
    CT
    sounds like a bad ground...
     
  4. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    Thats what I'm thinking but I'm having a hard time locating one. I was missing the one from the valve cover to the chassis by the headlight, but after install it made zero difference. Any ideas where to look? Thanks
     
  5. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    motor's already broken in?

    Anyway, bring the cam back to 0, fix the ignition timing. What exactly did you do to the distributor? And no, you won't really feel VTEC on a SOHC.
     
    Last edited: Jun 8, 2009
  6. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    you need to get the correct dizzy..and set the ignition timing correct..
     
  7. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    The motor has maybe 30-40 minutes on it. sounds like it runs realy smooth.
    I'll go and try those things and let you know how it goes.
    I had to grind out where the top bolt holds the distributor in. I'd been told it would work fine, just it would only have one bolt holding it in. I'll post locally for a Z6 dizzy here in a minute. Any ideas on the strange electrical occurances?
    Thanks guys, I appreciate the help!
     
  8. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    Would 2-3 degrees retarded make a big difference on power?
     
  9. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,582
    Likes Received:
    697
    Joined:
    May 20, 2003
    Location:
    Central, MA
    you would feel it. i dont have a camgear but im running emanage with all the fixins.

    right now im running about 10 degrees of advance on the mirage. gives it lots of low-end pickup but the top end suffers nominally.
    when i set it back to 0, the car has decent low and top power.
    when i retard it 5 degrees, the car is a hog.
     
  10. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    Ok cool. I checked for a spark and got none. I'm guessing this dizzy does Not work with this motor, lol. I posted a wtb add locally so hopefully I'll pick one up today or tomorrow. Thanks
     
  11. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
  12. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    Got the new dizzy. Didn't fix anything. The fuel pump wouldn't come on and I still wasn't getting any spark. After reataching the valve cover to chassis ground, removing the vtec ground which was ground in with another chassis ground, tightening the one on the thermostat housing, and bypassing my fuel cut-off switch, my fuel pump came on and I'm getting a spark.
    But it still won't start. It starts to crank but it sounds really weak and it slows down. The battery holds 12V and drops to 9V when cranking. Any ideas? Thanks
     
  13. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    O and the speedo jumped around a bit while trying to turn the engine over...
     
  14. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    MAP sensor read 5V. I even checked pins D19(+) and D21(-), and they were a little bit jumpy but were about 5V. While testing I heard a relay somewhere that would almost randomely switch on and off. Pretty sure it was under the driver side dash.
     
  15. Utrax42

    Utrax42 New Member

    Messages:
    91
    Likes Received:
    2
    Joined:
    Sep 25, 2008
    D17(+) and D21(-) show 3.54V so again I think I can rule out the MAP sensor. Distributor?
     
Verification:
Draft saved Draft deleted

Share This Page