1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no booost

Discussion in 'Forced Induction' started by turboef87, Jul 15, 2010.

  1. turboef87

    turboef87 New Member

    Messages:
    77
    Likes Received:
    1
    Joined:
    Nov 28, 2009
    Location:
    508
    i have no idea what the problem is i checked everywhere no leaks from piping or intercooler theres no oil coming out of the compressor side. i havent checked the exhaust side yet but when i drive it does not smoke. when i get on my car turbo builds about 2 or 3 psi of boost thatz itt i have a b16a with a turbonetics 50 trim 83ar hotside does any1 think the hotside of the turbo is 2 big and i cant spool it or wat ??? i have 2.25 piping from turbo 2 intercooler then 2.5 from intercoooler to throttle body there is no exhaust leaks. if it was my wastegate i think i would hear an exhaust leak right ?? i havent even heard my wastegate open up yet. im leaking oil from the top of the turbo wea the oil line connects to the turbo but i dnt think thatz the problem any1 help please is the turbo just not good for my motor or is it blown
     
  2. 95EGCoupeVtec

    95EGCoupeVtec SOHC VTEC at its best

    Messages:
    403
    Likes Received:
    1
    Joined:
    Aug 19, 2008
    Location:
    South Mississippi
    what kind of wastegate do you have and what psi is the spring rated for that's in the wastegate? also, are you running stock exhaust?
     
Verification:
Draft saved Draft deleted

Share This Page