1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No CEL with or without knock sensor.

Discussion in 'HYBRID -> EG-EK / DC' started by SiRG EJ1, Oct 26, 2004.

  1. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    There is no CEL when the knock sensor on my b18c is either plugged or unplugged. Could the ecu be fried maybe, or any other ideas as to what would cause this? Thanks in advance.
     
  2. UDT

    UDT Senior Member

    Messages:
    2,015
    Likes Received:
    0
    Joined:
    Sep 24, 2003
    Location:
    california


    Is the ECU obd1? Maybe its been chiped/programed not to even recognize the knock sensor. Or maybe the bulb for your CEL isint working or the CEL connections them self may be bad. Have you seen the CEL come on befor at all? Does it come on when you first start the car?
     
  3. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    well what ECU are you using? lol
     
  4. UDT

    UDT Senior Member

    Messages:
    2,015
    Likes Received:
    0
    Joined:
    Sep 24, 2003
    Location:
    california


    Good point :D :p
     
  5. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    It is a JDM P72 OBD1 ecu.

    The CEL works, I have fixed some other ones such as the IAT and IAB. I am 100% sure it works. The ecu is not chipped, I bought it with the swap from hmotorsonline and it is completely stock. <_<
     
  6. UDT

    UDT Senior Member

    Messages:
    2,015
    Likes Received:
    0
    Joined:
    Sep 24, 2003
    Location:
    california
    Sounds like it could be a problem wit hthe ECU but wait for a more expert opinion.
     
  7. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    if the ECU was fried you would have more problems than not showing a check engine light without the knock sensor attached

    i don't mean to be an asshole, but are you sure you're connecting and disconnecting the knock sensor?
     
  8. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    Yes, I'm sure its the right sensor. It's not the oil pressure sensor. ;)

    I read somewhere, I think honda-tech, that parts of the ecu can fry without affecting other parts. I have no clue. I'm going to take it apart tomorrow. Maybe the knock sensor just isn't making contact with the ecu. My friend kinda fucked up the connection where the pinout goes in. I can try replacing the whole D plug. But when the knock sensor isn't hooked up, won't it retard the ignition timing and affect the redline? My car's only redlining at 7000 RPM rigth now also. It should be 8200.
     
  9. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    I would consider giving the boys over at hmotors a call and tell them that they sent you a bunk ecu, see if they'll do anything for you?

    they didn't send me a mount with my swap and had no problem two daying one over to me at no cost-
     
  10. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    Sounds good, I might do that. I'm going to take the cover off and scope it out first to look for any fried areas.
     
  11. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004
    in my past experience, the ks won't throw a cel, the code will be present if you jump the service connector and check for codes, but it won't cause the cel to come on.
     
  12. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    Thanks for the info. I'll jump it and see if it gives me a code.
     
  13. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004
    this is the first time i've ever heard anyone complain about not getting a cel :p does the car run fine?
     
  14. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    No, it doesn't run fine. Vtec engages around 4000 and redlines 6800-7000. I'm thinking it might be the knock sensor, seeing that it puts the car in safe mode from what i hear-- retarding ignition timing, altering vtec, and changing redline.
     
  15. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004


    it's not the knock sensor, i've ran without a knock sensor on obd2 and obd1 and it ran normal.
     
  16. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    wonder what else it could be. ive heard plenty of stories about how the knock sensor will affect that though. ill jump the ecu to find out if its the ks.
    if not, i guess ill get a usdm p72 obd1 ecu and run that in the car to see if the car runs fine.
     
  17. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004
    you sure the ecu wasn't chipped?
     
  18. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    Not unless Hmotorsonline sold me a chipped ecu with my swap.
     
  19. projekteg

    projekteg Senior Member

    Messages:
    311
    Likes Received:
    0
    Joined:
    Oct 25, 2004



    very doubtful, just checking ;)
     
  20. SiRG EJ1

    SiRG EJ1 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Oct 17, 2004
    Location:
    Jacksonville, FL
    I jumped the ecu and it didnt give me a code... the light just came on and stayed whenever the paper clip was in.

    Next step would be swapping ecus with someone and see what that does. I've also been told it might be the distributor... iono though...
     
Verification:
Draft saved Draft deleted

Share This Page