1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

NO compression

Discussion in 'Engine Building' started by b18delsol, Oct 20, 2004.

  1. b18delsol

    b18delsol Member

    Messages:
    73
    Likes Received:
    0
    Joined:
    May 16, 2004
    I bought a B16A2 head and put a 95 GSR head on it. I put all the bolts and cams and timing belt on. When i spin the crank pulley there is no compression sound... what gives?
     
  2. Bl6CRX

    Bl6CRX Senior Member

    Messages:
    1,553
    Likes Received:
    0
    Joined:
    Jul 14, 2003
    Location:
    UCLA


    check the timming marks, especially the cam gears, maybe you got them switched around and so your getting valves open when you don't want
     
  3. 97CTR

    97CTR Senior Member

    Messages:
    745
    Likes Received:
    0
    Joined:
    Jul 10, 2003
    do you have the spark plugs in?
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    yup, tming, spark plugs
     
  5. b18delsol

    b18delsol Member

    Messages:
    73
    Likes Received:
    0
    Joined:
    May 16, 2004
    well the timing marks are fine and theres spark plugs and when i crank the pulley i heard compression but it is weak. is it a bad block?
     
  6. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,127
    Likes Received:
    1,020
    Joined:
    Aug 10, 2003


    wait. i just caught this, you put a b16a2 head on a 95 gsr head? :p
     
  7. b18delsol

    b18delsol Member

    Messages:
    73
    Likes Received:
    0
    Joined:
    May 16, 2004
    i meant B16A2 BLOCK with GSR head
     
Verification:
Draft saved Draft deleted

Share This Page