1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no muffler?

Discussion in 'Civic and del Sol - EG and EK' started by rcmaniac623, Jun 24, 2010.

  1. rcmaniac623

    rcmaniac623 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 13, 2010
    hey guys. well, i have put in a turbo and i feel like i have a big restriction when i drive on low end. i have a t25 turbo with 2.25 inch piping with magnaflow muffler. i was just wondering if removing the muffler will help? thanks
     
  2. OGMatt

    OGMatt Not a real OG lol

    Messages:
    1,326
    Likes Received:
    30
    Joined:
    Oct 4, 2008
    Location:
    vic B.C. Japanada
    like by 1hp. leave it on. less loud.
     
  3. K2e2vin

    K2e2vin Senior Member

    Messages:
    8,446
    Likes Received:
    92
    Joined:
    Jan 2, 2003
    Location:
    Raleigh, NC
    Maybe what you're experiencing is turbo lag?
     
  4. rcmaniac623

    rcmaniac623 New Member

    Messages:
    28
    Likes Received:
    0
    Joined:
    Mar 13, 2010
    oh yeh. thot so too. lol. i guess it is turbo lag. im idling way below 1000 rpm, like almost 0. im not sure if this is fine. it idles fine though.
     
  5. mcwheels

    mcwheels New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    May 25, 2010
    Yeah, it's turbo lag. Welcome to using a Turbo. use a Supercharger and see no lag, but some parasitic loss from another accessory run off of the crankshaft
     
Verification:
Draft saved Draft deleted

Share This Page