1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no rad. fan action

Discussion in 'General Tech and Maintenance' started by 2drunk, May 13, 2004.

  1. 2drunk

    2drunk Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    May 5, 2004
    just as i plopped down the cash for an auto to five speed conversion, bam.... problem. '94 ex d16z6 and my old lady was driving it when it overheated. checked it out and found radiator leaking on a busted seam. not a bad leak. i filled it up and took it for a spin, and no radiator fan action. fuses and relays ok, but no power coming from the pdc to kick fan on. i am four days out for an appointment at the local dealer. i need this car. i have a new fluidyne rad. for it, but need to fix this problem. any suggestions? coolant temp. sensor? i do not have a scan tool with asian software and this vehicle is not obd II or i would be a whole lot better off. thanks for any input.
     
  2. spaceman

    spaceman Member

    Messages:
    32
    Likes Received:
    0
    Joined:
    Apr 8, 2004
    check your wires make sure they are hooked up good...get a new sensor
     
  3. 2drunk

    2drunk Junior Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    May 5, 2004
    wires are all great. none severed. but, there is three coolant temp. sensors. one for the guage, one where the upper rad. hose goes into the block and where the lower hose goes into the block.
     
Verification:
Draft saved Draft deleted

Share This Page