1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No start after dizzy swap. Crx B16 P28

Discussion in 'ECU's, Electronics, and Tuning' started by phyregod, Aug 16, 2016.

  1. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    JDM B16, OBD1 P28 in a 91 CRX Si (using stock CRX harness with ECM adapter) had a very tired TD81U dizzy. Car started and ran and drove OK, like it needed a tune up. Found the rotor a little loose and the threads for the rotor absolutely trashed.

    Swapped the Dizzy for a New TD44U Dizzy (research suggested this was a better dizzy for the swap)

    Now it won't start. Fires here and there but "seems" to be firing way early. Rotated 180 degrees and no fire at all, so that wasn't it.

    I have double checked the wiring at the dizzy but I want to tone it all out to the ecm just to be sure. Haven't had time as of yet. Anyone see anything wrong with this setup? Am I missing something?
     
  2. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Toned it all out. Wiring is good. All I can guess is the new dizzy is crap or the timing belt skipped somehow. Will check the belt this weekend.
     
  3. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,449
    Likes Received:
    2,110
    Joined:
    Nov 18, 2007
    Location:
    CT
    The parts should be compatible, so it's likely a bad unit. Can you swap with a buddy for a known good test case?
     
  4. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    No good dizzy to swap out. Timing belt is dead on. l toned the wires color by color and even position but didn't check pin positions on the engine harness. Turns out the PO re-pinned the engine harness at the dizzy. I corrected that and it now starts hard, sluggish. Once running it idles and runs fine but cuts at ~3,000 rpm (tach not hooked up). It feels like it's in limp mode perhaps? Hoping I didn't fry the dizzy or ecm while it was wired wrong. Still picking at it but it's slow. I get to touch this car maybe once a month.
     
  5. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    The saga continues. Got to play with her a little this weekend. Very hard to start. Once it does it sputters for a minute or two then runs perfectly fine. Idles perfect. Drives fine but hits a fuel or ignition cut at 3250rpm. Tossed codes 22 and 41. Oxy heater (I believe there is a 1 wire installed) and VTEC pressure. Re-wired both VTEC wires with new wire and soldered connections. (Was patchwork twisted and taped). No improvement.
     
  6. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Ok. It was a bad dizzy. Bought another new dizzy and she's running like a champ!
     
    CAFROG and Briansol like this.
  7. Hondamechanic

    Hondamechanic New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 14, 2016
    I've got a d16z6 doing the same exact thing I can't figure out what's wrong with it. it's running on a p05 ecu tho should I be running a p28? its got a new dizzy and the engine is brand new. New plugs, wires, vtech system and wiring and a dizzy. and no change. when I drive it normally and don't go past 3/4 of the throttle it runs fine up until 3500 rpm and then ignition cuts or something. it just sputters and lunges and chokes as if It was being starved of fuel. if I go to full throttle then it down shifts and dose the same thing.
     
  8. phyregod

    phyregod !!YTINASNI

    Messages:
    9,449
    Likes Received:
    225
    Joined:
    Jun 11, 2005
    Location:
    Central Texas
    Double check your wiring. I had a brand new dizzy and had that issue so I chased ghosts for a while. Turns out the dizzy was crap. Now whether it came that way or something fried from being hooked up wrong, I cannot confirm or deny. As far as the ecm, the P28 was actually designed for your motor and has VTEC already. I'd use that if I were you.
     
  9. Hondamechanic

    Hondamechanic New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 14, 2016
    Alright thanks bro ! I'll get the ecu and if that doesn't fix it then Ill check the wiring
     
Verification:
Draft saved Draft deleted

Share This Page