1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nothing but problems.

Discussion in 'Engine Building' started by danny95ex, Jul 30, 2015.

  1. danny95ex

    danny95ex New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 28, 2015
    Have a stock b20b trying to get the ac installed has been nothing but problems. It her the wrong bracket or the wrong compressor I don't know what to do???
     
  2. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,448
    Likes Received:
    2,110
    Joined:
    Nov 18, 2007
    Location:
    CT
    yeah b20's ac doesn't work right, you need to get an integra ls bracket and use the civic ac compressor if you still have it. the b20 actually has a larger diameter crank pulley than the ls does, so you'll actually be doing a bit of over-driving the components and belts will be not the perfect fit.
     
  3. danny95ex

    danny95ex New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 28, 2015
    I got a ls bracket it does not line up with the stock compressor
     
  4. Briansol

    Briansol Admins Admin VIP

    Messages:
    21,448
    Likes Received:
    2,110
    Joined:
    Nov 18, 2007
    Location:
    CT
    right, you'll need to use the civic compressor, not the teg
     
  5. danny95ex

    danny95ex New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jul 28, 2015
    That's what I'm trying to tell you. The stock civic compressor does not match with the teg bracket
     
  6. serrilion

    serrilion In my own little world! VIP

    Messages:
    1,758
    Likes Received:
    42
    Joined:
    Aug 13, 2007
    Location:
    Vermont
    Sounds like someone may have given you the wrong compressor, normaly this is a quick simple swap, like said before the belts dont fit perfect but there damn near close, or someone gave you the wrong bracket, they are similar
     
Verification:
Draft saved Draft deleted

Share This Page