1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

o2 sensor relocation

Discussion in 'General Tech and Maintenance' started by FLounder, Apr 4, 2009.

  1. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
    i installed a new header today and the bung for the o2 sensor is in a bad spot. for one thing it doesnt reach because the bung faces straight sideways out of the collector pipe. also, it points at the transmission so it would be tight anyways, even if the wires were long enough.

    what should i do? will a muffler shop be able to weld in another bung in a better spot for me? theres plenty of room.
     
  2. jeffie7

    jeffie7 Wrong Whole! VIP

    Messages:
    12,926
    Likes Received:
    728
    Joined:
    Sep 28, 2002
    Location:
    Maryland
    Yup, just plug it and have a new bung welded into place.

    I have 4, o2s, EGT and Wideband in my car. yup, I had to weld a few more bungs to make it work. =)
     
    1 person likes this.
  3. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
    i have driven the car about 15 miles with the o2 sensor not in the exhaust and do not have a cel light on.... seems strange to me. readings should be out of range with it zip tied under the intake manifold. bad sensor??

    it seems to run completely normal just like always, ripping through vtec nicely with the new exhaust setup.
     
  4. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
    bump... should i assume that the o2 sensor is bad?
     
  5. newb

    newb phresh VIP

    Messages:
    3,967
    Likes Received:
    179
    Joined:
    Sep 17, 2007
    Location:
    Backwoods Northwest
    Usually if the sensor was bad youd get a CEL no matter where the sensor is. Is the CEL bulb itself workin?
     
  6. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
    yeah thats what i was thinking too, its weird. i have now driven it about 25 miles with no cel and still driving normal.

    yes the CEL definitely works.
     
Verification:
Draft saved Draft deleted

Share This Page