1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

O2 Sensor wiring?

Discussion in 'ECU's, Electronics, and Tuning' started by leonc, Jun 19, 2005.

  1. leonc

    leonc Senior Member

    Messages:
    182
    Likes Received:
    0
    Joined:
    Oct 10, 2002
    Location:
    Las Cruces
    I just got my b16a sir II into my 94 civic ex. I had to reroute my o2 sensor and the plug was missing off of the b16a exhaust so I had to cut the one from the d16z6 and put it on the b16a. I might have got some wires mixed up. I remember there where 2 blacks ( i assume grounds), one green, and one white on the 02 sensor side. but on the hareness side it was different colors (dont remember). Can anyone help me?

    Thanks
    Leon
     
  2. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    if the 2 blacks are swapped, the car won't run. ask me how i know. lol

    don't know why you cut though... shoulda jsut used the z6 harness and the z6 o2 sensor.
     
  3. leonc

    leonc Senior Member

    Messages:
    182
    Likes Received:
    0
    Joined:
    Oct 10, 2002
    Location:
    Las Cruces
    how do you know? lol

    ya i guess i could have done that, but i wasn't sure if the z6 and b16 had the same 02 sensors. still learning. do you know what wires should be connect from o2 to harness?
     
  4. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
  5. leonc

    leonc Senior Member

    Messages:
    182
    Likes Received:
    0
    Joined:
    Oct 10, 2002
    Location:
    Las Cruces
    Thanks for the links but i have an civic ex. I believe it has a 4 wire plug on the harness. So i was wondering what colors matched to the colors of the o2 sensor becuase the harness side colors are not 2 blacks, green, and white.
     
  6. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    yeah, don't worry about the colors so much on the engine harness.

    just get the 4-wire back into its orig confirguration, and plug it in. you'll be good.


    [​IMG]
     
Verification:
Draft saved Draft deleted

Share This Page