1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OBD2a vs OBD2b

Discussion in 'ECU's, Electronics, and Tuning' started by reckedracing, Nov 17, 2008.

  1. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    I have a 98 CRV we're doing a B20 swap in. (rod knock)

    We picked up a JDM motor with no crank sensor and did the CKF Bypass Trick as found here.
    .:FFS TechNet : CKF Bypass Trick :.

    This CRV has a production date of 8/98, but everything I've found says a 98 Honda should be OBD2a.

    This CRV doesn't have the wires listed in that article for the OBD2a. Could this be an 98 OBD2b?
     
  2. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
    96-97 obd2a
    98-99 obd2b
     
  3. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    where did you find that?
     
  4. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
  5. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
    are you sure its a 98? whats the 10th letter in the vin? usually after june or july of a calender year the new models are being made, since you are after june Im suspecting that your motor may have been wired for obd2b to meet the market standards
     
  6. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    its registered as a 1998 crv
    date of production on the door says 8/98
    don't have the 10th letter of the VIN off hand, but i can check it
    what should it be?

    so we got this motor all back in
    have fuel (2 years old, its been sitting)
    has decent spark

    we swapped the intake and exhaust manifolds (intake for emissions BS, and exhaust cause they were different

    this this will crank and pop but will not run
    if you crank it and unplug the injectors it will pop, then nothing, plug them back in then unplug them and it will pop a couple times, then plug them back in and nothing, unplug them and get a few more pops

    we pulled compression on #1 and it was only 117
    figured the rings were set up, put oil in the cylinders and cranked it some more
    2nd compression test pulled 200+ across the board

    i know oil will bump compression but i don't think it does miracles like that, so i assume the motor has decent compression

    can't figure it out

    what if we swapped out a 9.6:1 compression motor with a 8.8:1 compression motor
    could the fuel maps be that off that its flooding the motor out?
     
    Last edited: Nov 17, 2008
  7. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
    you need to look the vins, you compression figures seem a little high, however that probley from doing the wet compression test. I think your orginal motor is the 8.8 to1 compression and your new motor is the 9.6 to 1.

    Have you checked fuel pressure? you said it sat for 2 years? I would drain the gas tank,and replace the fuel tank pump filter and the fuel filter, Also I would blow the fuel lines out with high pressure air.
     
  8. t3t4delsol

    t3t4delsol New Member

    Messages:
    652
    Likes Received:
    12
    Joined:
    Mar 18, 2008
    Location:
    York, Pa
    Do you have any starting fluid or ether? remove the intake pipe, hold the butterfly on the throttle body open and have a friend start is while you spray
     
  9. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    the stock motor should have been 9.6:1
    i'm thinking the replacement motor is the 8.8:1 motor from a 96-97 JDM crv

    fuel doesn't seem to be an issue, the plugs are coming out wet every time

    B20B 1973 126@5400 133@4300 8.8:1 84 89 dohc no 2 1997-1998 CRV
    B20Z 1973 146@6400 133@4500 9.6:1 84 89 dohc no 2 1998-2001 CRV
     
    Last edited: Nov 17, 2008
  10. 94H_Ex

    94H_Ex Under employed

    Messages:
    1,453
    Likes Received:
    33
    Joined:
    Jun 17, 2008
    Location:
    Florida
    you have a lack of spark.
    now you need a test light. test for power coming into your dizzy. either two things are happening. your coil is bad, or your coil igniter module is bad.
     
  11. reckedracing

    reckedracing TTIWWOP VIP

    Messages:
    21,056
    Likes Received:
    1,180
    Joined:
    Dec 5, 2002
    Location:
    NY
    how do you figure its a lack of spark?
    we've got spark

     
  12. civic4g63

    civic4g63 New Member

    Messages:
    77
    Likes Received:
    0
    Joined:
    Sep 29, 2007
    Location:
    fl 1 hot place
    did you check an see if you have all the grounds connected?
     
Verification:
Draft saved Draft deleted

Share This Page