1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OIL LIGHT FLICKERS , HELP PLEASE

Discussion in 'HYBRID -> EG-EK / DC' started by NCHATCH, Aug 24, 2003.

  1. NCHATCH

    NCHATCH Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Jan 26, 2003
    okay i have a turbo on my civic right and i heard that 15-w50 is a good oil for turbo hondas. so i did the change parked it, go to drive it tonight and the oil light flickers on and off.

    so i change the sending unit, change oil back to 5-w30, and it doesnt come on at an idle or when im driving.

    but if i just barely give it a slight pop on the throttle(SAFC says like 2%) real quick, the rpms drop to like 600, and the oil light blinks but goes back off when the rpms go back to normal idle.

    is this just like an almost stalling thing, and the oil pressure just gets low at that rpm??

    what is normal idle oil psi? my book says 10@idle 50@3000??

    i hooked up a gauge and @ idle i make 16psi.

    when i pop the gas its just barely like an 1/8 of an inch, is my car just going thru stalling procedures or am i screwed, the motor only has like 2000 miles since it was built up.



    it never comes on at any time, i have no noise from my motor other than normal.

    HELP PLEASE
     
  2. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,129
    Likes Received:
    1,020
    Joined:
    Aug 10, 2003
    my oil light only used to flick at me when I'd never check it and it would get bone dry, but the kicker is the cams would never click when hitting the rockers.

    Are you sure the oil pump is pumping the oil? Do you have an oil pressure gauge? That would help tremendously to figure out what's going on under driving conditions.
     
  3. Havok

    Havok Senior Member

    Messages:
    6,827
    Likes Received:
    1
    Joined:
    Sep 28, 2002
    Location:
    Florida
    my car does the exact same thing...the oil light flashes for 1/2 a second at around 500-600 rpms when I start it up..I have no idea what makes it do it. :(
     
  4. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,129
    Likes Received:
    1,020
    Joined:
    Aug 10, 2003

    Wait...do you both mean when you first start it up and then it doesn't flash at all when driving?

    It's supposed to do that...all cars are. It's the testing "thing" the car goes through on startup.
     
  5. vtecsir1

    vtecsir1 Senior Member

    Messages:
    3,313
    Likes Received:
    17
    Joined:
    Dec 5, 2002
    Location:
    Orlando, FL
    could be some blockage maybe, the oil light comes on normally when no oil is getting to the head i have been told.
     
  6. NCHATCH

    NCHATCH Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Jan 26, 2003
    no, it does it when im idleing and i give the gas a kwik pop, and my rpms shudder down to like 550-600,
     
  7. rudeludenotmeanthough

    rudeludenotmeanthough Senior Member

    Messages:
    1,406
    Likes Received:
    0
    Joined:
    Sep 29, 2002
    My car only does it in hard cornering.

    http://www.hondaswap.com/forums/index.php?...showtopic=19273

    Dunno how it relates to your prob. But its information. take it for what it is. When was the last time you did an oil change, changing the oil filter and such? Also how many mile does your car have?
     
  8. bossman032

    bossman032 Senior Member

    Messages:
    216
    Likes Received:
    0
    Joined:
    Dec 22, 2002
    you guys better get the OIL light fixed.

    you don't want a ROD to shoot out on the freeway when comming home or u do? ;)
     
  9. NCHATCH

    NCHATCH Member

    Messages:
    69
    Likes Received:
    0
    Joined:
    Jan 26, 2003
    nevermind, all good, switched to mobile 1 15w50, no light and better pressure
     
Verification:
Draft saved Draft deleted

Share This Page