1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oil Light

Discussion in 'Civic and CRX - EF' started by GlassHeadlights, Apr 4, 2009.

  1. GlassHeadlights

    GlassHeadlights West West Yall

    Messages:
    4,066
    Likes Received:
    71
    Joined:
    Oct 24, 2007
    Location:
    Calgary, AB
    You know when you turn the ignition to "on" and you get the check engine light, voltage light and oil pressure light. Well my oil pressure light only comes on some times.

    Just say the car sat over night and you start it in the morning, the light will be on when you go to start it. But just say you turn it off for 10 minutes and go to start it again. The light will not come on, it still thinks there is pressure.

    It never did it before I did my mini me swap. What I'm thinking of is the oil jet I removed out of the block, the ECU, my wiring or the sensor its self.
     
    Last edited: Apr 4, 2009
  2. INJEN78

    INJEN78 HS LEGEND

    Messages:
    9,187
    Likes Received:
    121
    Joined:
    Oct 1, 2007
    Location:
    OHIO
    its probably because of the jet,i wouldnt really worry about it
     
  3. OGMatt

    OGMatt Not a real OG lol

    Messages:
    1,326
    Likes Received:
    30
    Joined:
    Oct 4, 2008
    Location:
    vic B.C. Japanada
    Oh shit brad time for a new car!
     
  4. monotech

    monotech Member

    Messages:
    299
    Likes Received:
    5
    Joined:
    Nov 13, 2006
    Sounds like Oil pump may be going bad which can cause your engine to blow. Make sure you have a good connection for the oil pressure sensor and and if so then look into replacing your oil pump.
     
  5. GlassHeadlights

    GlassHeadlights West West Yall

    Messages:
    4,066
    Likes Received:
    71
    Joined:
    Oct 24, 2007
    Location:
    Calgary, AB
    I highly doubt it's the oil pump.
     
Verification:
Draft saved Draft deleted

Share This Page