1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

oil sending unit

Discussion in 'Integra' started by joeyjames, Mar 18, 2007.

  1. joeyjames

    joeyjames New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Mar 18, 2007
    Location:
    sarnia,ontario
    i'm trying to find where the oil sending unit is...

    my car losses oil pressure and check engine light comes on car boggs alittle but lots of oil is getting to the top of the engine and it dosen't leak oil...

    my guage gives a wrong reading for sure,
    my car is the 1990 civic dx
    i have the 86-89 integra zc motor 1.6L dohc

    but today everything has been running good no problems ,so i'm thinking maybe lose wire or something is just giving me the wrong reading and telling my computer there is a problem when there isen't one.

    if anybody can give me a good pic of the back of the engine so i know everything is hooked up ok that would be awesome

    and i have concern about my cooling fan on the rad...if that dosen't work ,would it affect what i have mentioned above?
     
    Last edited: Mar 18, 2007
  2. hazzardboy95

    hazzardboy95 Hon-daaaa

    Messages:
    671
    Likes Received:
    0
    Joined:
    Dec 5, 2006
    Location:
    Pasadena, Md
    Shouldnt, the cooling fan not comming on wouldnt bring up a c.e.l because it doesnt read if the fan is working it reads if the motor is over heating.
     
Verification:
Draft saved Draft deleted

Share This Page