1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

over heating

Discussion in 'Forced Induction' started by custompainter, Apr 23, 2007.

  1. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
    alright guys here we go i just posted this on another thread but now we're getting into another prob.
    i just got do hooking my y8 up with a turbo everything is in and seems to be working just fine i've got a nice spool up and it holds it well with not sputtering.
    the other day i was driving down the highway and my temp started getting really hot. now i wasn't riding on the boost it was driveing normal anyway it when up for a bit then it leaved back off.
    the next night i went up to the races with it in hartford and when we split from the cops it started over heating again. so i took it home pulling over on the highway every five minutes to cool off.
    so yesterday i pulled out the termo, and replaced it bleed the system for air and checked everything that i could. the only thing i didn't was a presure test on the cylinders.
    anyway i left the damn thing running in my driveway for about an hour and it ran fine nothing......... so i jumped in it took it up the road and donn RT66 and next thing you know it's heating up again. brought it back and checked everything my coolant looked to be a little low from when i had just filled it but there was no sign of where it went.

    i dont think it's the head gasket ? i'm thinking the water jacket on the turbo might be cracked and i'm loosing coolant through there .
    Or has any one here of the turbo heating the oil up so much that the car over heats like this.
    can anyone think of anything to help
     
    Last edited: Apr 23, 2007
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    does your fan come on like normal
     
  3. custompainter

    custompainter drive it like U stole it

    Messages:
    597
    Likes Received:
    4
    Joined:
    Jan 16, 2007
    Location:
    central CT
    found the problem it was my head gasket i'm selling the turbo system if you know anyone who wants it let me know i have it listed in the forsale posts of this site pics check em if your interested
     
Verification:
Draft saved Draft deleted

Share This Page