1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

p28 problems??

Discussion in 'ECU's, Electronics, and Tuning' started by dcdenonda, Sep 11, 2007.

  1. dcdenonda

    dcdenonda New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 18, 2007
    Location:
    Alexandria, VA
    i gotta a p28 running my ef with a 1.6L VTEC. the car will not go over 3000rpms. is this ecu and vtec related? is there some wiring problems? problem is, it doesnt constantly happen, its on a off. im in the process of changing some fuel components, fuel pump and fuel filter, but im wondering what the cause of the problem is. any ideas?

    also anyone in the NOVA area that can double check my VTEC wiring work? just want another opinion/help to see if i did the wiring correctly.
     
    Last edited: Sep 11, 2007
  2. awptickes

    awptickes unimpressed by you VIP

    Messages:
    9,272
    Likes Received:
    497
    Joined:
    Aug 29, 2007
    Location:
    MD
    Sounds like it's in "limp" or engine protect mode.

    There are several causes for this, but the easiest way to fix this is to unplug the ECU, wait a bit, then plug it back in. If after that you're still in limp mode, check the knock sensor.
     
  3. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
  4. dcdenonda

    dcdenonda New Member

    Messages:
    7
    Likes Received:
    0
    Joined:
    Jan 18, 2007
    Location:
    Alexandria, VA
    well if tried a new dizzy, and where would the knock sensor be? ive tried unpluggin the ecu many times, so imma try the knock sensor, but what am i looking for?
     
Verification:
Draft saved Draft deleted

Share This Page