1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help!

Discussion in 'HYBRID -> EG-EK / DC' started by itsbigmike, Jul 7, 2003.

  1. itsbigmike

    itsbigmike Junior Member

    Messages:
    24
    Likes Received:
    0
    Joined:
    May 25, 2003
    Okay, got a 95 b18b in a 93 civic. runs beautiful, but it doesn't go anywhere. Was running a cable clutch with the hasport conversion, I could shift gears, plenty of clutch pressure, etc, but yea, the car didn't drive. So, I thought maybe the clutch was bad, so I took off the tranny, and the thing was near brand new, but to be safe I put on a new clutch, pressure plate, and flywheel, then I said hmm, maybe I'll throw a hydraulic tranny on there. Today, go back to the shop its at, start it up, put it in gear, try to back up, same thing.....Anyone ever hear of anything like this?
    I need help pretty bad, my mechanic is something of an idiot, but one of his guys he called over to help from Honda is kinda wondering what the hell too.
    Thanks
     
  2. darwins_vtech

    darwins_vtech Senior Member

    Messages:
    250
    Likes Received:
    0
    Joined:
    Jun 4, 2003
    Location:
    Wisconsin
    did you put axels in and are they the right ones?

    Darin
     
  3. itsbigmike

    itsbigmike Junior Member

    Messages:
    24
    Likes Received:
    0
    Joined:
    May 25, 2003
    yea, they're b18 axles with the abs rings......went in easy and everything, maybe I'll just double check tomorrow morning
     
Verification:
Draft saved Draft deleted

Share This Page