1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Prelude gauge cluster question (with swap)

Discussion in 'General Tech and Maintenance' started by Luded, Jan 8, 2006.

  1. Luded

    Luded Member

    Messages:
    93
    Likes Received:
    0
    Joined:
    Nov 7, 2005
    Location:
    Tennessee
    Hi i have a 92 lude s non vtec and it had the red line at 6500ish and the h22a red lines at 7500ish the s stock gauge goes up to 140 and the vtec cluster goes to 200. Do i have to replace my s cluster with a vtec cluster when i swap or can i still use the s cluster and just ignore the red line etc?
     
  2. VTECPOWER

    VTECPOWER Senior Member

    Messages:
    1,683
    Likes Received:
    0
    Joined:
    Oct 6, 2003
    Location:
    Winchester, VA
    Just use the stock cluster, the redline is for the motor, just rev it til the motor's redline (not all the time) just whenever you want to.
     
  3. Luded

    Luded Member

    Messages:
    93
    Likes Received:
    0
    Joined:
    Nov 7, 2005
    Location:
    Tennessee
    so none of the sensors will be off? b/c i am going to replace the cluster later with all digital so i dont wanna buy a vtec cluster then buy digital.
     
  4. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    yeah youll be fine with the stock cluster. Itll scare you (and your friends) if you rev it up to 7500+, but your engine will be fine. The cluster wont cause any harm.
     
Verification:
Draft saved Draft deleted

Share This Page