1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem after swapping head

Discussion in 'General Tech and Maintenance' started by erebunicrx, Sep 13, 2004.

  1. erebunicrx

    erebunicrx my name is Dale

    Messages:
    2,110
    Likes Received:
    1
    Joined:
    Jun 13, 2003
    Location:
    Bristol ct
    i just put a 95 ls head on my ls and now i have really low compression in the 2 middle cylinders. before i started the head swap i did a compression test and got
    185 +- 1 all the way accross. now after adj the valves to spec and puting all new gaskets on i only read 170, 145, 125,170. i put oil in the cylinder with 125 and jumped to 155. do you guys have any idea what the hell happened.
     
  2. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    do a leakdown test

    did you torque the headbolts in the right order and to the correct torque specs?
     
  3. erebunicrx

    erebunicrx my name is Dale

    Messages:
    2,110
    Likes Received:
    1
    Joined:
    Jun 13, 2003
    Location:
    Bristol ct
    yup. i will try a leakdown tommorow
     
  4. Slammed90Lude

    Slammed90Lude Senior Member

    Messages:
    3,733
    Likes Received:
    0
    Joined:
    Jan 13, 2003
    Location:
    milford, PA
    nice, let me know how it goes-
     
  5. erebunicrx

    erebunicrx my name is Dale

    Messages:
    2,110
    Likes Received:
    1
    Joined:
    Jun 13, 2003
    Location:
    Bristol ct
    ok no prob. anyone else have any ideas?
     
Verification:
Draft saved Draft deleted

Share This Page