1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem with my d15 b1 motor

Discussion in 'Civic and CRX - EF' started by 91hondacivcdx_man, Dec 26, 2008.

  1. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    i'm having a problem with my d15 b1 motor. every time the car starts to warm up the car dies. then i let it cool and it will start again i have replaced the pcv valve also did a tune up and it didn't start doin this till i replaced my heater core a couple of days ago . can any one help me with this problem
     
  2. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    and check codes showing up on the ecu
     
  3. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    there aren't any codes that pop up . I found a couple of wires that had come disconnected and now it turns over but won't start i made sure i put the wires back where they went and now i have one grey wire that i don't know where it goes i 've looked in the haynes manual and still cant find that wire anywhere but it s where the wires go to my engine can anyone help me with this ?? please help
     
  4. disableddan

    disableddan Crazy Insane

    Messages:
    367
    Likes Received:
    6
    Joined:
    Sep 22, 2008
    Location:
    Edmonton Canada, Eh?
    Yikes did you disconnect a bunch of wires then reconnect them?
     
  5. D16SiHatch

    D16SiHatch New Member

    Messages:
    1,297
    Likes Received:
    44
    Joined:
    Sep 7, 2007
    a pictures would help..
     
  6. OGMatt

    OGMatt Not a real OG lol

    Messages:
    1,326
    Likes Received:
    30
    Joined:
    Oct 4, 2008
    Location:
    vic B.C. Japanada
    Check the ground wire! done.
     
  7. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    i will get pics up hopefully tomorrow and hopefully it helps . no I didn't disconnect the wires they were broken and i put them back to the wires that they broke from . so thanks i will show all you guys a pick of the wire i have left and maybe you all can help thanks again
     
  8. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    i know i've had this thread for a while now but i'm now having another problem got the wiring prob fixed now the car will start momentarally then the throttle body fills with fuel and the car dies really quick too . If anyone can help me on this thread please respond. i'm thinking it might be the fuel pressure regulator but like i said before i'm new to this type of motor
     
  9. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    it could be or a bad comp,
     
  10. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    would a bad comp make my fuel spray more than needed ??
     
  11. AHHVTEC

    AHHVTEC Well-Known Member VIP

    Messages:
    13,122
    Likes Received:
    245
    Joined:
    Oct 13, 2006
    Location:
    Alabama
    it could but i would try the regulator first
     
  12. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    i hope thats it . i know when i first bought the car i ran injector cleaner through it and i have had to replace the fuel filter a few times since . i know now its not having a problem gettin fuel so i'll try that and post soon thanks very much
     
  13. Reboticon

    Reboticon New Member

    Messages:
    48
    Likes Received:
    0
    Joined:
    Oct 7, 2008
    Location:
    Knoxville
    What ecu do you use for a d15b1?
     
  14. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    i havent got into it yet i will look tomorrow let ya know i think its the one that came with the car . would it make my fuel shoot through the top of my round bowl on the top of my throttle body ? i also asked a friend of mine who works mostly on semis he said that it could be that my timing belt could have thrown a tooth or a bad injector . like i said though he works on semis not cars so i m gonna look into it and get back to u all later thanks again for all the help.
     
  15. 91hondacivcdx_man

    91hondacivcdx_man for the love of hondas

    Messages:
    26
    Likes Received:
    0
    Joined:
    Dec 12, 2008
    Location:
    salt lake city utah
    well it turns out that i had two different problems . first it was my fuel pressure regulator i replaced it and it stopped squirting fuel outta my throttle body . and the second thing was while i was trying to get my car to run i threw my timing belt off it jumped about 3or 4 teeth , so i pulled my timing cover and noticed that i was way off and readjusted the the timing and now i have no problem anymore so if anyone has this same problem please read this thread and hopefully it will help you correct this type of prob ... thanks to the people who offered me help, i look forward to getting advice again if i have any other probs. thanks again
     
Verification:
Draft saved Draft deleted

Share This Page