1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems Still

Discussion in 'HYBRID -> EG-EK / DC' started by ThatGuy4life, Jan 8, 2007.

  1. ThatGuy4life

    ThatGuy4life The Riced Sleeper

    Messages:
    1,478
    Likes Received:
    14
    Joined:
    Nov 27, 2006
    Location:
    Albuquerque, NM
    I'm getting to the point where I'm just bout to take my car in to the dealership and see if they can figure out what's wrong. Keeps throwing random cels first it was throwing all 4 misfires reset the ecu code went away then threw a code for knock sensor that went away after about 30 minutes then the misfire codes came back, replaced ignition wires car rode perfectly for a day then the knock sensor code came back along with a manufacturer ignition malfunction code.

    Main problem though is while driving once I hit 5500 rpm in all gears the motor stutters/hesitates it will just stay at 5500 for about 6-8 seconds if I stay on the pedal it'll eventually catch up and take off. Ignition system is good, I thought it might've been the ecu as I was still using the si ecu but put in a chipped skunk2 ecu on Friday and it's doing the same thing. The only choices I'm left with are either the timing or fuel system. Anybody have any ideas?

    See setup below:

    2000 si with Built B18C5-type R motor
    Head is ported & polished
    Crower rods
    JE pistons
    Skunk 2 stage camshafts
    Skunk 2 intake manifold
    REV Valves Springs & Retainers
    Act Flywheel
    RPS Six Puck Sprung Hub Clutch
    AEM Cam Gears
    AEM Fuel Rail
    STR Cam Seal
    Stock LS headers soon to be JDM type R 4-1 headers
    Polished K2 cold air intake
    Throttle body spacer
    APC Cat-Back Exhaust
    NGK Ignition Wires
     
  2. welfare

    welfare Ancient Member

    Messages:
    1,120
    Likes Received:
    9
    Joined:
    Apr 19, 2004
    Location:
    New York
    You say ignition system is good, I would say ignition system is bad, get some new plugs to start, then go to your cap and rotor (i see you already did your wires)
    I have a supercharged gsr and it started hesitating around 5200, changed my plugs to ngk iridiums and the problem is gone.
    i would also suggest getting a p73 ecu the p30 may be leaning out the engine a little, which would cause you to foul the plugs. . .
    hope it helps!
     
  3. ThatGuy4life

    ThatGuy4life The Riced Sleeper

    Messages:
    1,478
    Likes Received:
    14
    Joined:
    Nov 27, 2006
    Location:
    Albuquerque, NM
    i'm already running new ngk iridiums to complimemt the ngk wires
     
  4. welfare

    welfare Ancient Member

    Messages:
    1,120
    Likes Received:
    9
    Joined:
    Apr 19, 2004
    Location:
    New York
    ok, replace the cap and rotor, if you keep getting misfire codes after you have changed all of that, then maybe have your fuel pump checked, but to me it sounds ignition related.
     
Verification:
Draft saved Draft deleted

Share This Page