1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems with 90 teg

Discussion in 'HYBRID -> ED-EF / DA' started by terribbleteg90, May 23, 2007.

  1. terribbleteg90

    terribbleteg90 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    May 22, 2007
    Location:
    casa grande az
    i recently rebuilt my 90 teg motor b18a1 because a buddy of mine threw the number 2 rod throught the block so i put a brand new block nippon pistons acs rods and mains new stroked crank and gsr connecting rods its all back together with the old head it has 240000 miles on the head now my car will not rev above 3000 rpms at first it would do 4000 but i could slowly rev it up and it would only go to 6000 now its got nothin but 3000 no matter what i do what could the problem be any ideas i never had the head inspected just slapped it back on thinkin it would be all good i also put a brand new water pump and a brand new dizzy i got 2200 dollars in just the bottom end and cant use it could it be the connecting rods or maybe the head is bad please help any help will save an ass load of money i hope thx alot guys
     
    Last edited: May 23, 2007
  2. delsol_racer

    delsol_racer Junior Member

    Messages:
    176
    Likes Received:
    0
    Joined:
    Aug 2, 2006
    Location:
    watsonville ca
    maybe your ecu is bad i have tha same promblem im trying to figure out myself also i heard it could be tha tps i would start with checking all tha wires again and maybe your dizzy is bad idk thoguh. i have a 89 crx with a jdm b16a and wont rev more than 3000 check you oil maybe u have a blowen head gasket?

    GOODLUCK
     
  3. Black Widow g2

    Black Widow g2 *princess*

    Messages:
    3,599
    Likes Received:
    31
    Joined:
    Oct 18, 2004
    Location:
    California
    i would have said it was your distributor but it sounds like something else. do you have a check engine light?
     
  4. terribbleteg90

    terribbleteg90 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    May 22, 2007
    Location:
    casa grande az
    well i pulled the head off today and the cylinders were full of water the head was warped like a bitch the pistons and all that stuff r still good tho it wasnt sittin with water to long but ya i think that was one of the problems with it lol but im still worried about the revin problem im hopin this new motor im gettin works out and fixes the problem
     
  5. klyph

    klyph Dismember VIP

    Messages:
    6,342
    Likes Received:
    262
    Joined:
    Aug 14, 2006
    Location:
    North Pole, AK
    Should've had the head checked before putting a 200K+ head on a fresh shortblock. Can you mill the head straight again, or is it too far gone?
     
  6. terribbleteg90

    terribbleteg90 New Member

    Messages:
    18
    Likes Received:
    0
    Joined:
    May 22, 2007
    Location:
    casa grande az
    i think its too far gone its all good i got another motor on the way thx tho
     
  7. freak86

    freak86 New Member

    Messages:
    287
    Likes Received:
    0
    Joined:
    Jul 28, 2006
    Location:
    Southwest Michigan
    like del sol racer's comment said... it's probably your head gasket leaking =causing you to lose compression.
     
Verification:
Draft saved Draft deleted

Share This Page