1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problems with my B20 swap

Discussion in 'HYBRID -> EG-EK / DC' started by xlerate93, Jul 8, 2003.

  1. xlerate93

    xlerate93 Member

    Messages:
    73
    Likes Received:
    0
    Joined:
    Mar 3, 2003
    Location:
    Waterbury, CT
    the swap ive been working on for the past 2 days is nearly completed.
    although i have a couple things holding me back

    first, the main hose that leads from the bottom of the radiator to the block, there is a small piece in between the two and i have a hose connector that i cannot find anything to connect it with. what does it connect to?

    secondly i have two clips that i cannot find anywhere for them to connect with, some people say look harder and some say that i do not use the clips

    also on the gsr transaxle i do not have a bracket for the shift linkage stabalizer bar, does anyone happen to have a pic of how the bracket mounts to the tranny? apparently my d series does not fit.

    i have pics but my cable is down, i will try and upload them soon

    please guys try and help me

    im is xlerate93

    :(

    edit- it is going into a 93 del sol Si
     
  2. b20_ek

    b20_ek Member

    Messages:
    44
    Likes Received:
    0
    Joined:
    Jun 5, 2003
    Location:
    Palmdale

    damn sounds confusing. wish I could help.
     
  3. E_SolSi

    E_SolSi Member of the 20 nut club Moderator VIP

    Messages:
    30,036
    Likes Received:
    3,970
    Joined:
    Sep 28, 2002
    Location:
    CT
    not too sure on the hose .... need a pic
    the 2 extra plugs should be for VTEC... are they up near the distributor both round 1 grey 1 green? if so you dont use them
    for the linkage i just used a bolt that fit the hole and a big ass washer to make sure it stayed in place
     
  4. solblu

    solblu Senior Member

    Messages:
    378
    Likes Received:
    0
    Joined:
    Jan 17, 2003
    Location:
    Ricer
    You need the VTEC Shift linkage and hardware, It's about $150 for everything from Hpars.com

    As for the clips, if you are using your Z6 engine harness they are the VTEC clips. (near the distributor right)

    I'm not sure what you mean about the Hose. Is there a neck on the motor without a hose??
     
  5. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    took care of the shift linkage today.... he has the right stuff... jsut was missing a bolt...
    and it looks like his injecotrs are ok too...
     
Verification:
Draft saved Draft deleted

Share This Page