1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems...

Discussion in 'General Tech and Maintenance' started by wtc7676, May 4, 2003.

  1. wtc7676

    wtc7676 Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Feb 2, 2003
    Location:
    Columbus, Ga
    Okay, I have a 93 civic coupe with a 95 GSR w/ JRSC. It has been running fine...but now when I crank it up it revs to 4000 rpms, then go down to 1000 rpms and revs back and forth between 1000 and 3000...

    Can anyone help?


    thanks,

    Will
     
  2. B16

    B16 Super Moderator VIP

    Messages:
    11,539
    Likes Received:
    534
    Joined:
    Sep 30, 2002
    Location:
    yay area, CA
    say what?
     
  3. DA69

    DA69 Senior Member

    Messages:
    340
    Likes Received:
    0
    Joined:
    Apr 18, 2003
    Location:
    psl Fl.
    sounds like it could be a few things. one is a vacum leak. check for that if you know how to. (with carb cleaner) 2 is the eacv sensor on the back of the manifold, another is the TPS sensor on the throttle body and one more sensor is the fast idle control valve which is also on the throttle body and has coolant lines on it. all of these can cause that problem. the only way i know how to fix that is trial and error. meaning replace one and if it doesnt fix it then replace another. hope it helps
     
  4. wtc7676

    wtc7676 Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Feb 2, 2003
    Location:
    Columbus, Ga
    Thanks for the info...I'll start trying all of them
     
  5. superchargedcivic

    superchargedcivic Junior Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 5, 2003
    wtc look at the topic high idle and read my advice. i have same probs as you but its sorted now. let me know how you get on
     
Verification:
Draft saved Draft deleted

Share This Page