1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rack and pinion HELP

Discussion in 'HYBRID -> ED-EF / DA' started by formby, May 7, 2005.

  1. formby

    formby learning in progress

    Messages:
    5,735
    Likes Received:
    23
    Joined:
    Feb 19, 2003
    when i'm driving and i go to down shift or when i decelerate then acelerate fast...i hear/feel something knocking (loose) agaist the floor board by the clutch pedal..


    so i checked under the car and it seems like the rack and pinion is shot......when i 5turn the wheel from one side to the other (fast) i hear it rattle around....



    i have a 91 std crx; can i use any EF rack????

    i checked ebay nothing....where could i get a new or rebuild? i am going to check the local yards


    any info is apreciated
     
  2. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs

    you can't use any EF rack as the EF is the 88-91 JDM cars which have right hand drive - you can however, use any 88-91 USDM ED CRX/Civic rack
     
  3. formby

    formby learning in progress

    Messages:
    5,735
    Likes Received:
    23
    Joined:
    Feb 19, 2003
    ohh okay...

    so as long as its 88-91 usdm civic 2-3-4 door it will fit?
     
  4. jlicrx

    jlicrx Senior Member

    Messages:
    1,891
    Likes Received:
    65
    Joined:
    Jun 5, 2003
    Location:
    Colorado Springs

    yes, unless it is power steering
     
  5. racintweek

    racintweek Senior Member

    Messages:
    743
    Likes Received:
    0
    Joined:
    Mar 13, 2004
    Location:
    Arlington VA
    since we are on the topic of steering racks, i have heard the CRX Si has a different ratio in the rack for more responsive steering.
    is this true??
     
  6. formby

    formby learning in progress

    Messages:
    5,735
    Likes Received:
    23
    Joined:
    Feb 19, 2003
    good question....

    but it wasnt the rack...i guess i over tightened the camber adjuster...so the bolt broke....i put a new one and it did the same thing...lol...thank god i have more....
     
Verification:
Draft saved Draft deleted

Share This Page