1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Radiator Fan Doesnt Work

Discussion in 'General Tech and Maintenance' started by GSRCRXsi, Apr 14, 2003.

  1. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,622
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    i know its not a big deal but i dont know why it doesnt work. i just noticed it the other day. its plugged in and everything. any ideas?
     
  2. BigJ

    BigJ I'm just about that action Boss. VIP

    Messages:
    11,090
    Likes Received:
    408
    Joined:
    Oct 4, 2002
    Location:
    Washington
    I know on my 93 hatchback si my fan stopped working for some reason so I checked the in hood area fuses and sure enough it was blown, replaced it and now it works. Make sure all the fuses are working and the connectors are good.
     
  3. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,622
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    does anyone know wha fuse controls the radiator fan in a 91 CRX si? i looked at the fuses under the hood and under the dash but didnt find anything that was ratiator fan.
     
  4. ilikepie

    ilikepie Senior Member

    Messages:
    416
    Likes Received:
    0
    Joined:
    Nov 21, 2002
    my radiator fan went out in my integra a few months ago. just take a wire and hook the fans directly up to your battery.. if it works, then overide the temp sensor. if it works then its your fuse. not to hard to hard to figure out :p good luck
     
Verification:
Draft saved Draft deleted

Share This Page