1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Radiator Fan Fuse Has No Power!

Discussion in 'ECU's, Electronics, and Tuning' started by Hybrid93Hatch, Apr 19, 2003.

  1. Hybrid93Hatch

    Hybrid93Hatch Member

    Messages:
    42
    Likes Received:
    0
    Joined:
    Oct 27, 2002
    I am having an over heating problem because my radiator fan will NOT come on. I tested the fan it works fine. Yesterday I realized the harness that plugs into the fan is nto getting any power. Today, I just pulled the fuse from the fuse box (for the radiator fan) under the hood near the battery and tested for power with the multimeter. Not getting ANY power (key turned to ON (II) position). Pulled the hazard fuse and turned the switch for the hazards on and power is there!

    Where do I check now? Is there something inside the fuse box that can be bad / not working? Maybe a disconnected wire?

    Thanks for any help!
     
  2. solblu

    solblu Senior Member

    Messages:
    378
    Likes Received:
    0
    Joined:
    Jan 17, 2003
    Location:
    Ricer
    Check the relay. Would need to know what car you had to tell you where it is.
     
  3. Hybrid93Hatch

    Hybrid93Hatch Member

    Messages:
    42
    Likes Received:
    0
    Joined:
    Oct 27, 2002

    Already pulled the relay from the 98 Civic and swapped it with the 93 civic.
    I need to just go over all the fuses under the dash. For now I have the fan wired in to a toggle switch / accessory wire. Not over-heating anymore :)
     
Verification:
Draft saved Draft deleted

Share This Page