1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

really strange problem

Discussion in 'ECU's, Electronics, and Tuning' started by adnoh, Jan 10, 2006.

  1. adnoh

    adnoh Senior Member

    Messages:
    1,016
    Likes Received:
    1
    Joined:
    Dec 22, 2003
    Location:
    Ontario
    Hey guys,

    The past 5 times I've gone out and driven my car for 40 minutes or more EXACTLY, my speedo goes crazy, then dies, and I throw a code. If I turn my car off, then on, the code dissapears. Really wierd.

    I've tried to get the code to come on constantly, but it won't stay.

    I've recently changed my battery, alternator, and thermostat, so I don't think it's anything to do with those.

    Now, my question is: If I throw a code, is there some sort of memory built into the ECU that will remember it? Basically, if I'm not currently throwing a code, does the ECU keep a record of the last one thrown? Meaning, can I flash the ECU to diagnose the code if my engine light isn't currently on?

    Thanks for any help.

    If it matters, I'm running a JDM P30 OBD1
     
  2. adnoh

    adnoh Senior Member

    Messages:
    1,016
    Likes Received:
    1
    Joined:
    Dec 22, 2003
    Location:
    Ontario
    Bump :)
     
  3. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    id say check your engine grounds. sounds like the notorius ELD.
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    the N.O.T.O.R.I.O.U.S ELD

    lol thats great.

    there's a chance that you can pull the code from the computer.
    the second you see it come on, shut down the car, pull off the road... and pull it right then and there. leave the key on...
    like, just turn the key back 1 click to shut it off but it will leave the acessory power on.

    ok course, use some judgement and don't kill yourself or others in the process :)
     
  5. adnoh

    adnoh Senior Member

    Messages:
    1,016
    Likes Received:
    1
    Joined:
    Dec 22, 2003
    Location:
    Ontario
    Thanks guys, that's a good idea.

    So what does the N.O.T.O.R.I.O.U.S. ELD Entail? Never heard of it.....
     
  6. reikoshea

    reikoshea HS Troll...And Mod Moderator VIP

    Messages:
    12,633
    Likes Received:
    193
    Joined:
    Apr 27, 2005
    Location:
    San Antonio, TX
    just grounds comming loose or not connected at all. itll make your guage cluster whig out too. thats the only reason i suggest it.
     
  7. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    54
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    electric load detector. basically it detects if you're going up a hill, etc etc... changes the maps a little bit. a free rev has next to no load (why you can't really build boost) and a rev while in 3rd gear will have a lot of load.

    the eld is in the dsitributor
     
  8. adnoh

    adnoh Senior Member

    Messages:
    1,016
    Likes Received:
    1
    Joined:
    Dec 22, 2003
    Location:
    Ontario
    Well, found out what my problem is. It's code 17, so my speed sensor on the tranny is the problem. Thats why the speedo went all crazy, then the engine light came on. I checked the sensor and the middle pin was almost completely corroded. I sourced out the sensor and am going to solder it in sometime soon.


    Thanks for the help.
     
Verification:
Draft saved Draft deleted

Share This Page