1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rebuild

Discussion in 'Engine Building' started by killahrican, Jan 14, 2008.

  1. killahrican

    killahrican New Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Jan 2, 2008
    Ok well long story short, was installing headers bolt snapped. Friend drilled and tapped and finished install. Only to find out his dumb ass drilled through the head breaching the oil and collant holes. Took to the machine shop they said they could weld it and retap. Picked it up slaped it back on adjusted timing and everything. The car starts and seems like its going to shut off but slowly maintains idle but then goes up to about 2. It doesnt overheat but when you give it gas and let go it turns off. Check engine light is on as well.

    Another problem we had which i dont know if it might be the problem is that the knock sensor was messed up i put one from a 96 prelude. Would that be the issue?

    Anyone with advice please respond. Im dying to get this car fixed its my daily driver.
     
  2. dtob

    dtob New Member

    Messages:
    578
    Likes Received:
    2
    Joined:
    Mar 18, 2007
    Maybe check your codes.

    You car can most likely tell you what the problem is.
     
  3. Taco15

    Taco15 I wear stretchy pants VIP

    Messages:
    6,998
    Likes Received:
    203
    Joined:
    Jan 11, 2005
    Location:
    Tallahassee Fl

    def, start there.
     
Verification:
Draft saved Draft deleted

Share This Page