1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

serious idle problems, and i'm in the dark

Discussion in 'General Tech and Maintenance' started by jewls, Nov 10, 2003.

  1. jewls

    jewls Junior Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Nov 10, 2003
    i own a 90 crx, with a b18a1(91 integra)
    the idle is jumping from 1500-3000 and back down again. i have tried just about everything, and taken it to shops, but no one knows what is up. i've checked vaccuum lines and all is well. injectors are not the prob, i tried distributor, tps, throttle body, map sensor, coolant temp sensor, alternator, 02 sensor, done vaccuum test, compression test reads 200 across, fuel pressure reg, u name it, i've probably ruled it out. if anyone has any clue, as to what the problem may be, i would love to hear about it. none of my teachers at university know(i'm in level 1 in auto tech) adn i'm running out of ideas. i've been trying to figure it out for at least 6 months, so i'm getting pretty pissed off about it. thanks for reading, and for you ideas, Jewlz
     
  2. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,623
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    did you check your TB gasket, your Intake Manifold gasket, or your IAC Valve?
     
  3. Accordturbo94

    Accordturbo94 Senior Member

    Messages:
    920
    Likes Received:
    0
    Joined:
    Nov 18, 2002
    hey dude i had the same problem on my h22! I started it when it was cold and it went straight to 3k untill it warmed up than the up and down from 1400-3000! thats not a vaccum leak thats way to big of a jump! I found out it was my intake manifold.. somehow from always launchin it it brok everysingle nut off the top studs to the intake manifold! I couldnt believe it...
     
  4. Sunkist

    Sunkist Junior Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Nov 9, 2003
    I am in no means a mechanic but did know someone who did the swap with a certifeid honda mechanic, and he said it was the ECU that made it rev like that. The scenario might be a little different in each case but just wanted to let you know what he said

    B
     
  5. EGLSHB

    EGLSHB Senior Member

    Messages:
    396
    Likes Received:
    0
    Joined:
    Dec 27, 2002
    IACV on the back of the intake mani. has two screens in it.... there are 2 12mm bolts that hold it on, and you need to get a stiff bristled brush, and clean out those screens...

    that might fix it, if you haven't done it yet
     
  6. Guy

    Guy Senior Member

    Messages:
    784
    Likes Received:
    0
    Joined:
    Sep 4, 2003
    Location:
    Yuba County
    If its doing it all the time, it may be what my b18 was doing back when i had my integra. I remember going to three different mechanics and none of them could figure it out. It very possibly could be your Fast Idle Thermo Valve (thats what my chiltons called it) It is located on the intake manifold, i think below the opening for your intake. Ill look at my car later and see if i can give you more specific info. HTH
     
  7. Accordturbo94

    Accordturbo94 Senior Member

    Messages:
    920
    Likes Received:
    0
    Joined:
    Nov 18, 2002
    They are on the throttlebody! On Accords And preludes, I could be wrong on a diffrent honda, but im still thinkin that thermo idle valve is on the throttle body!
     
  8. Guy

    Guy Senior Member

    Messages:
    784
    Likes Received:
    0
    Joined:
    Sep 4, 2003
    Location:
    Yuba County
    yeah its just below the opening of the t-body and has two hoses running to it (on mine at least)
     
  9. jewls

    jewls Junior Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Nov 10, 2003
    thanks ppl. i'll try that fast idle thermo valve. i know exactly what your talking about that. definately worth a try. i'll keep you all posted.
    Jewlz :D
     
  10. jewls

    jewls Junior Member

    Messages:
    11
    Likes Received:
    0
    Joined:
    Nov 10, 2003
    just letting you know, that it was infact the Fast Idle Thermo Valve, and it feels great to have it running right again. it could use a tune up, so i'll do that this weekend, and then it should be running great. thank u so much. this was bothering me a lot for the past like 6 months.
    Jewlz
     
  11. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    read the article section..
    i wrote one on erratic idles.
     
  12. GSRCRXsi

    GSRCRXsi Super Moderator Moderator VIP

    Messages:
    9,623
    Likes Received:
    345
    Joined:
    Nov 13, 2002
    Location:
    MD
    does fast idle thermal valve = IAC valve?
     
  13. gocivicls

    gocivicls Senior Member

    Messages:
    266
    Likes Received:
    0
    Joined:
    Apr 20, 2003
    Location:
    forest city, NC

    No!!!! IAC is on the back of the IM on B18b's!

    Fast idle thermo vavle is on the bottom of the TB!!
     
  14. ahedau

    ahedau Senior Member

    Messages:
    647
    Likes Received:
    0
    Joined:
    Nov 24, 2002
    Location:
    Middle GA



    do what this guys says....it helped fix my irratic idle.
     
  15. Vtec=V8 killa

    Vtec=V8 killa Member

    Messages:
    38
    Likes Received:
    0
    Joined:
    Oct 29, 2003
    if you say compression is 200 accross, dont know if boosted or not but my trusted Acura shop manual says 185 is stock compression for that engine????
     
  16. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH

    well thanks yO! glad i could be of service
     
Verification:
Draft saved Draft deleted

Share This Page