1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

si cluster swap problems

Discussion in 'Civic and CRX - EF' started by 89y49rexsi, Sep 22, 2009.

  1. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    hey guys i either have a short or a bad ground but i cant find it sometimes when i turn my blinker left my tach will jump up and down sometimes it wontother times when i pull my ebrake the tach will go to 0rpm other times it wontsome times when i turn my lights on my stereo shuts off other times it doesntsome times when i press the brake my tach will go nuts other times it wontthe gas gauge and temp guage have decided to switch positions with each other, which wouldnt be all that bad except the fact that the gas/temp guage decides where it wants to be not where it should be i drive an 89 civic dx sedanit has a d15b2 at the momenti put in my crx si cluster from my 89 crx si i have done alot of reseach and it should be plug and play but it aperently isnt so any help would be nice
     
  2. 89hatchd15b

    89hatchd15b now its a 91

    Messages:
    102
    Likes Received:
    1
    Joined:
    Mar 20, 2007
    Location:
    Acton, CA
    do you still have the dx cluster? If you do see if it works properly. It sounds like a short to me, you might have to trace it back through the harness. Or it could be a bad ground somewhere.
     
  3. Battle Pope

    Battle Pope New Member

    Messages:
    10,279
    Likes Received:
    60
    Joined:
    Jun 22, 2004
    Location:
    Southern Oregon Coast
    Yeah, reinstall your DX cluster and see if it clears up, it could be a bad connection between the harness and the cluster, or a problem in the cluster itself. There shouldn't be any compatibility problems with the cluster itself.
     
  4. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    the dx cluster did it too the only difference is that the fuel guage was the fuel guage and it did work everything else though was the same and the cluster works properly it came out of my crx and there was nothing wrong with it at all
     
  5. 89hatchd15b

    89hatchd15b now its a 91

    Messages:
    102
    Likes Received:
    1
    Joined:
    Mar 20, 2007
    Location:
    Acton, CA
    I would check the grounds, then check the harness for shorts/loose connectors (I have never seen a loose connector on a Honda unless the plug is broken) or even the ecu could be bad.
     
  6. 89y49rexsi

    89y49rexsi New Member

    Messages:
    114
    Likes Received:
    0
    Joined:
    Aug 6, 2009
    Location:
    utah
    well i think ive figured it out and im pretty sure that its the main ground and the fuse box ground they are both way too small and they are both hooked up pretty wierd so im going to change them out for bigger wire and relocate them and hook it all up right loli will let yall know how it goes when im done =)
     
Verification:
Draft saved Draft deleted

Share This Page