1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sign of a bad tps?

Discussion in 'Integra' started by makemagick, Jun 24, 2013.

  1. makemagick

    makemagick Member

    Messages:
    85
    Likes Received:
    0
    Joined:
    May 30, 2012
    once in a while i let my car go on neutral from any speed, and while its rolling the RPMs are around 1.5 and they only go down once you come to a complete stop, there is a crack in the plastic of my TPS so i was wondering if it could be the TPS sensor fucking with my RPMS.

    Oh and also when i just start the car my rpms drop down to 0.5 and then the car goes to 0.7 while warming up, after it warms up it goes back to normal around .8, however if you rev it right from the start (to like 3 rpm, just a slight gas pedal kick) it start from 1.0 1.1 and goes down to 0.8.

    I'm running 68mm blox throttle body, and there is no idle adjust.
     
  2. phunky.buddha

    phunky.buddha Admin with a big stick Admin VIP

    Messages:
    28,465
    Likes Received:
    228
    Joined:
    Sep 30, 2002
    Location:
    Dallas / Fort Worth, TX
    Vacuum leak?
     
  3. FLounder

    FLounder power hungry VIP

    Messages:
    2,419
    Likes Received:
    137
    Joined:
    Jun 11, 2008
    Location:
    north palm beach, FL
  4. makemagick

    makemagick Member

    Messages:
    85
    Likes Received:
    0
    Joined:
    May 30, 2012
    Thought so too, but cleaned it n still the same, hmm leak maybeeee but if it is, its in some very unnocibale place cause i checked vacuum quite a few times, b4 i changed the throttle however at the start it used to.rev up to like 2 n the as warmed up came down to .7-.8
     
  5. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,582
    Likes Received:
    697
    Joined:
    May 20, 2003
    Location:
    Central, MA
    you can also check leaks with some soapy water in a spray bottle.

    that is how i found some intake manifold leaks on the elantra. the idle would settle down when the leak was "stopped" momentarily.
     
  6. makemagick

    makemagick Member

    Messages:
    85
    Likes Received:
    0
    Joined:
    May 30, 2012
    will try on the weekend, thank you
     
  7. makemagick

    makemagick Member

    Messages:
    85
    Likes Received:
    0
    Joined:
    May 30, 2012
    checked for leaks, didnt notice any so threw in a new sensor, now the car starts at 1.6 , which im happy with. However it starts bouncings from 1.3 to 1.6, but again if i rev it a bit, it fixes itself for.good. still not perfect but way bettrr than it ws
     
  8. CAFROG

    CAFROG Honda Minion VIP

    Messages:
    4,417
    Likes Received:
    154
    Joined:
    Apr 5, 2009
    Location:
    NOR-CAL
    I recommend you take off the IACV and see if it needs a cleaning. It could be the culprit in the intermittent hunting idle.
     
Verification:
Draft saved Draft deleted

Share This Page