1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

skunk 2 intake on b18

Discussion in 'Engine Building' started by londoncrx, Dec 11, 2009.

  1. londoncrx

    londoncrx New Member

    Messages:
    67
    Likes Received:
    0
    Joined:
    Mar 1, 2009
    i am putting a skunk 2 mani in and when i went to start the car it started but revved at 5000 and i cant get it to go down any suggestions
     
  2. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    is the throttle cable too tight?... are u sure there arent any vacuum leaks now?
     
  3. londoncrx

    londoncrx New Member

    Messages:
    67
    Likes Received:
    0
    Joined:
    Mar 1, 2009
    i took the throttle cable completly off but theres a lil male end coming out of it that i cant find a place to run it to but i put my finger over it and didnt help any but do u think 440 injectors would flood it out i know it has nuthin to do with the revving jw
     
  4. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    is it boosted?? fully built all-motor?? if not, 440's are overkill.. OEM 240's will be suffice
     
  5. londoncrx

    londoncrx New Member

    Messages:
    67
    Likes Received:
    0
    Joined:
    Mar 1, 2009
    yeh just all motor i wasnt for sure to use them or not, but i still cant figure out the intake
     
  6. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    my guess is you have a vacuum leak ...

    do you know how to check for one?
     
  7. londoncrx

    londoncrx New Member

    Messages:
    67
    Likes Received:
    0
    Joined:
    Mar 1, 2009
    not really just put my finger on a hole and see if it pulls in lol
     
  8. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    .. alright.. since you've just replaced the manifold and probably didnt even torque it down correctly.. its most likely a leak..

    sooo

    step one: grab some carb cleaner
    step two: start the car
    step three: spray the carb cleaner around the base of the manifold and anything and everything attached to it... if the idle changes while you're spraying carb cleaner in said places then thats where its leaking from
    step four: fix your leak..
     
  9. londoncrx

    londoncrx New Member

    Messages:
    67
    Likes Received:
    0
    Joined:
    Mar 1, 2009
    ohh makes sense thanx
     
Verification:
Draft saved Draft deleted

Share This Page