1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

small truck rant

Discussion in 'Members' Lounge' started by BodyDroppedNikes, Dec 4, 2005.

  1. BodyDroppedNikes

    BodyDroppedNikes ...PENDEJO.... VIP

    Messages:
    10,593
    Likes Received:
    103
    Joined:
    Sep 28, 2002
    Location:
    caught in a mosh...
    it seems like in the past month i have had nothing but problems with my truck (95 Splash with 3.0L v6 for reference). a few weeks ago my engine temperature gauge started fluctuating so i put a new thermostat in it. a few days go by and it started doing it again. so the badger, i replaced the engine temperature sensor and that worked. around $15 total for both of that to fix that problem.

    earlier this week, i been having problems starting my truck. it would barely start up and would idle at like 500 rpms but would idle normal after a few minutes of driving. i got my friend to check my battery with a volt meter and he said the battery was fine. so today i went to Advance Auto and had them check it and my alternator. the battery tested fine. he checked my alternator and said i may need a new one soon cause its dying. i would have had them run a diagnostic on it but i was running late for work. so tonite after bowling, i went to start my truck and it wouldnt turn over but it started fine about 2 hours ago with no problems other than the idle was a little higher than normal. so luckily my friend was there with his car and he gave me a jump and it started up. what the hell is going on with my truck? im starting to get pissed at the damn thing. oh and for further reference, it wont start good when its really cold out. i really dont have the money for a new (well re-manufactured) alternator and im getting frustrated period with the truck. this sucks. someone come buy this piece of shit from me or some shit...lol.

    anyone got any ideas whats going on with my truck??
     
  2. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,117
    Likes Received:
    1,015
    Joined:
    Aug 10, 2003
    Oh sure... just refer to me as your friend and don't even mention my name. I see how it is. :p

    When you went to start it when we left, did the starter even try to start or did it just click? (or neither?)

    Might be the ignition switch or module. Remember when you broke the switch on the Escort? lol Yours might be starting to go on the truck. (both Mazda/Fords... see the correlation?)
     
  3. ripperbone

    ripperbone angry bear

    Messages:
    3,173
    Likes Received:
    8
    Joined:
    Oct 20, 2004
    Location:
    Oklahoma
    heres a clue F.O.R.D.

    nah j/p. :p

    I am guessing its the alt.
     
  4. BodyDroppedNikes

    BodyDroppedNikes ...PENDEJO.... VIP

    Messages:
    10,593
    Likes Received:
    103
    Joined:
    Sep 28, 2002
    Location:
    caught in a mosh...
    no its not the ignition cause it turned like its supposed to when i went to start it. the starter solenoid was clicking like its supposed to (?). hell i dont know shit about engines....im clueless to those god damn things.
     
  5. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,117
    Likes Received:
    1,015
    Joined:
    Aug 10, 2003
    Ok... the clicking is your ignition kicking on.

    The starter worked right away when we jumped it. How old is that battery anyway?
     
  6. BodyDroppedNikes

    BodyDroppedNikes ...PENDEJO.... VIP

    Messages:
    10,593
    Likes Received:
    103
    Joined:
    Sep 28, 2002
    Location:
    caught in a mosh...
    the battery is old and it has corrosion on it BUT when i had it tested today at Advance Auto, their diagnostic machine said it was good.
     
  7. Battle Pope

    Battle Pope New Member

    Messages:
    10,279
    Likes Received:
    60
    Joined:
    Jun 22, 2004
    Location:
    Southern Oregon Coast
    Ford alternators really suck.
     
  8. jamesA

    jamesA Well known pissed off telephone guy VIP

    Messages:
    16,117
    Likes Received:
    1,015
    Joined:
    Aug 10, 2003
    Replace the battery first IMO. Its cheaper and easier to do than the alternator. If it isn't the battery, at least you have a new one.

    I'm about there with you, my battery is gettin old... I've jumped so many peoples cars with this thing. haha
     
  9. BodyDroppedNikes

    BodyDroppedNikes ...PENDEJO.... VIP

    Messages:
    10,593
    Likes Received:
    103
    Joined:
    Sep 28, 2002
    Location:
    caught in a mosh...
    aight, one guy on a Ford Ranger site said it could be the fuse thats used to power the alternator might be shot. he said his was doing the same thing last year, he replaced it and it worked fine. i'll have to check it out.
     
  10. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
    i thought you were selling that thing anyway?? lol

    clean up the corrosion... even if the battery is good, if it can't connect, its usweless...
     
  11. 93vicb16a2

    93vicb16a2 WHATS CRACKIN??

    Messages:
    410
    Likes Received:
    0
    Joined:
    Jul 24, 2005
    Location:
    bfe
    they circled the problem right on the front

    j/k

    i am with pissedoffsol about the corrosion
     
  12. BodyDroppedNikes

    BodyDroppedNikes ...PENDEJO.... VIP

    Messages:
    10,593
    Likes Received:
    103
    Joined:
    Sep 28, 2002
    Location:
    caught in a mosh...
    well i bought a new battery today for it. put it right in and fired up....3 times. so far so good. im going to give it a couple days to see how it does. if it goes back to what it was doing, im going to go ahead and get a new alternator for it.
     
  13. StealthMode

    StealthMode Kung Foolin'

    Messages:
    2,150
    Likes Received:
    2
    Joined:
    Mar 12, 2003
    Location:
    Thornton, CO
  14. Celerity

    Celerity Well-Known Member

    Messages:
    21,969
    Likes Received:
    146
    Joined:
    Sep 11, 2003
    I wish I could say "Just kidding" but I'm not.

    It's a goddam Ford. This thing is NEW and it gives you more issues than my 35 year old Toyotas ever did - even over the course of their 35 years.
     
Verification:
Draft saved Draft deleted

Share This Page