1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SMOKIN!!!!!NEED HELP!!!!!

Discussion in 'Engine Building' started by 95civic2nr16, Apr 18, 2006.

  1. 95civic2nr16

    95civic2nr16 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Mar 13, 2004
    Alright here is the run down....i put the zex 59300 cam in this thing last summer so almost a year.....i adjusted the lifters and the car has been running great for as along as i can remember......around christmas time i noticed that the car started to leak oil.....it was coming from the distributor.....i replaced the seal no leaks.....however when i took the dizzy off again to replace the cap and rotor....i cracked my cam....got a new zex cam put it in and now the car runs alittle roungh and it is smoking like crazy on start up and running down the road????

    I took the cam out again and re-installed it thinking that i forgot to do something of something wasnt right....STILL SMOKING...

    the car has a turbo on it and a bunch of other stuff.....im out of ideas on this one....

    the odor smells like burning oil....but i dont no

    i think that i might need to replace the seals under the springs.....what do you guys think??????
     
  2. CRX-YEM

    CRX-YEM Super Moderator Moderator VIP

    Messages:
    4,623
    Likes Received:
    54
    Joined:
    Sep 29, 2002
    Location:
    Wallingford, CT
    valve seals come to mind.

    other than that if it's not blueish in color it could be a head gasket, but then again it would also smell like coolant
     
  3. TurboMirage

    TurboMirage YEEAAAHHH VIP

    Messages:
    24,582
    Likes Received:
    697
    Joined:
    May 20, 2003
    Location:
    Central, MA
    seems like timing may be off, or the cam could possibly be different?
     
  4. 95civic2nr16

    95civic2nr16 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Mar 13, 2004
    timing is def not off i set it checked it set it again and checked it.......

    timing light put on it timing is perfect..
     
Verification:
Draft saved Draft deleted

Share This Page