1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Suspension Setups

Discussion in 'Members' Lounge' started by endlesszeal, Sep 2, 2007.

  1. endlesszeal

    endlesszeal Senior Member

    Messages:
    2,670
    Likes Received:
    35
    Joined:
    Nov 13, 2002
    Hey guys, I know this is in the wrong thread, but no one ever reads the other sections and this is somewhat an emergency.

    Anyway, Im in the middle of repalcing my shoes for the rear drums :ph34r: of an 00' Accord. My dad noticed that on both sides, there is a little peice of rod that looks like its snapped. It is supposed to be that? It looks like its supposed to be conncted to the rear sway bar, but then again we dont know if its supposed be like that.

    Thanks in advance. BTW will delete this thread when question gets answered.
     
  2. endlesszeal

    endlesszeal Senior Member

    Messages:
    2,670
    Likes Received:
    35
    Joined:
    Nov 13, 2002
    [​IMG]
     
  3. eg6sir

    eg6sir Supa Mod Moderator VIP

    Messages:
    21,703
    Likes Received:
    321
    Joined:
    Aug 17, 2005
    Location:
    661 BK CA
    have you tried lining it up with anything to see where it broke from.. look for any spots were it may have been attached together.. :shrug: other than that.. i have no idea
     
  4. ScrapinSi

    ScrapinSi Senior Member

    Messages:
    3,292
    Likes Received:
    4
    Joined:
    Feb 27, 2003
    Take some other pictures from different angles. That does look like a Swaybar Endlink for an accord... but it almost looks like it was cut, not broken.
     
Verification:
Draft saved Draft deleted

Share This Page