1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

swappin out a d16 with a b16a2...ecu troubles

Discussion in 'ECU's, Electronics, and Tuning' started by Elayna, Jul 11, 2009.

  1. Elayna

    Elayna New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    Location:
    New York
    swappin out a 98 civic hx v-tech with a CVT tranny to a b16a2 v-tech with a manual . everything is changed over, shifter is in and i even found the rare p30 to go with it. heres the problem, my iac valve has no ground. its throwing the code for "iac valve system fault" and idles at like 200rpms. you hit the throttle to idle at around 1100 and it skips at you. a steady bop. could my computer be fried or what? did i miss something? the plug for the IAC was swapped froma 3-wire to a 2-wire cause the plugs were diferent from my stock harness to the new motor. please hurry...i need my baby back.
     
  2. tabKola

    tabKola New Member

    Messages:
    326
    Likes Received:
    5
    Joined:
    Jul 3, 2008
    Location:
    Tewksbury MA
    Did you just change out the plug at the IACV itself or did you also switch the wires at the ECU because to do the 3 wire to 2 wire fix you have to do both.
     
  3. Elayna

    Elayna New Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jul 11, 2009
    Location:
    New York
    thanks just found that out. thanks for the quick response. Everything else seems to be working as it should but just in case is there anything else i should keep an eye out for? anyone else do a swap like this and have any major issues?
     
Verification:
Draft saved Draft deleted

Share This Page