1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The realtek rtl_8185 ubuntu solution

Discussion in 'Computers, Games, Electronics etc' started by cjvictoria, Apr 13, 2009.

  1. cjvictoria

    cjvictoria New Member

    Likes Received:
    Sep 22, 2008
    N. Chuck, SC
    If you know what the rtl-8185 chipset is, it's safe to say it's probably really pissing you off....

    Follow my guide for Ubuntu 7.x - 8.04 to get that fucker working.


    note: some of the 'sudo' commands in this tutorial will need to be prefixed with 'gk'
    gksudo <then the rest>

    If it won't work with a lone sudo, slap a gk on it, and it should do the desired command correctly.
    Those of you who don't yet have build essential will need to do this first:

    note2: i used "||>" and "<||" as a way to show the start, > and end, < of each command. You don't need to add the space before and after each command.

    ||> sudo apt-get install build-essential <||

    Then open /etc/modprobe.d/blacklist (HINT: add gk to sudo)

    ||> sudo gedit /etc/modprobe.d/blacklist <||


    And add the following to the bottom if it is not already there.

    (type exactly these two lines in there)

    blacklist r8180
    blacklist r8185


    Then download the drivers and ndiswrapper

    ||> wget,UI_1.00.0006.zip <||
    ||> wget http://superb-west.dl.sourceforge.net/sourceforge/ndiswrapper/ndiswrapper-1.50.tar.gz <||

    alternatively, if you possess a driver disc with a more current W2000 driver for your chipset/pci card, then use that, but remember you will have to go to that specific disc's directory for the final install of the driver.

    P1 next page >>>

    once those have downloaded untar the ndiswrapper and install

    ||> tar -xvzf ndiswrapper-1.50.tar.gz <||

    ||> cd ndiswrapper-1.50 <||

    ||> sudo make uninstall <||

    ||> make <||

    ||> sudo make install <||


    Now that ndiswrapper has been installed, it is time to install the drivers.

    Option 1
    If you have a disc with drivers:
    This is where that driver disc comes in if you have it. You will need to go to the driver's directory no matter where it is, to run this command correctly. So, if you've got the disc, locate the directory in
    your file browser, and change directory to the containing folder of ' net8185.inf'.

    Option 2
    If you don't have the driver disc:
    I use the archive manager and extract the files in the Win2000 folder.
    There should be three of them.
    To install them after you extract them/locate them in the disc.

    ||> sudo ndiswrapper -i net8185.inf <||


    Check to see if it worked

    ||> ndiswrapper -l <||

    should show you the installed driver.


    Now activate the driver
    ||> sudo modprobe ndiswrapper <||

    p2 next page >>>>


    To get it to run at startup. Edit the modules file. (HINT: add gk to sudo)

    ||> sudo gedit /etc/modules <||

    and place the following at the bottom


    Everything should work fine now.

    Once all that is done you can delete the extra folders and files that have been created in you working directory. To see those files type the following in terminal.
    ||> ls <||

    I would save the ndiswrapper tar file and the 3 drivers.

    This is a modified version of a tutorial by the user |v|eph of ubuntu forums.

    I did the exact process to the T of what he posted and it worked great, I just added a few things here and there (no code though) just to help clarify some details that I struggled with. You can see the original at :

    Problem with RTL8185 in gutsy - Ubuntu Forums
    Last edited: Apr 13, 2009
Draft saved Draft deleted

Share This Page