1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Throwing CEL

Discussion in 'HYBRID -> EG-EK / DC' started by Teal_HB, Oct 11, 2004.

  1. Teal_HB

    Teal_HB Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Oct 9, 2004
    Location:
    Portland, OR
    Hey I am getting a code 14-IAC Valve (Idle Air Control) defective circuit or unplugged / defective sensor and a code 41-Primary Oxygen Sensor - Heater circuit malfunction. After I replaced my P05 ecu in my 94 hatch with a P28 so that I could run vtec. I have already ran all my vtec wires and now when I try and run my car it is extremly loppy and will die. 14, and 41 are the codes my CEL is throwing. Any help on what I should do? Also I have a 1 wire O2 sensor right now do I need to run it diffrently with the D16Y8 with a P28.
     
  2. xj0hnx

    xj0hnx I wanna be sedated VIP

    Messages:
    14,172
    Likes Received:
    48
    Joined:
    Nov 10, 2002
    Location:
    C.C.TX.
    Yes, you have to rewire to the four wire o2, there's a how to in the articles section. In the same one, there is a link to the IAC fix.
     
  3. Teal_HB

    Teal_HB Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Oct 9, 2004
    Location:
    Portland, OR
    I could not find the link you are talking about. I was also wondering if the IAC sensor was working fine when I had my P05 ECU in and now that I have put my P28 in, if maybe it was because it needed to be wired to diffrent pinouts on the P28. Could this be and if somone could post this link that would be nice. Thanks
     
  4. pissedoffsol

    pissedoffsol RETIRED

    Messages:
    49,693
    Likes Received:
    53
    Joined:
    Sep 28, 2002
    Location:
    Retirement Home
  5. Teal_HB

    Teal_HB Member

    Messages:
    40
    Likes Received:
    0
    Joined:
    Oct 9, 2004
    Location:
    Portland, OR
    Actually I have accomplished getting a new 4 wire O2 sensor and wiring if correctyl to my ECU. Now my problem is that I am getting a code 14 which is the code for malfunctioning IAC. That is what I was wondering if anyone had any advice on fixing.
     
Verification:
Draft saved Draft deleted

Share This Page