1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ticking sound in my 94 LS

Discussion in 'General Tech and Maintenance' started by Dustinr42, Jul 23, 2003.

  1. Dustinr42

    Dustinr42 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Mar 8, 2003
    Im rollin home from pizza hut and my timing belt snaps. Three hours proir to this i installed my B&M shortshifter. I take it to this guy that said he would fix it. I got my car today and there is now a tick.

    When im flooring it in 1st, 2nd and 3rd the tick just increases with the rpm's.

    Someone help

    (it seems like the car lost power too) Does anyone want to get rid of a stock ls motor? let me know
     
  2. B16

    B16 Super Moderator VIP

    Messages:
    11,539
    Likes Received:
    534
    Joined:
    Sep 30, 2002
    Location:
    yay area, CA
    valve lash, relash the valves.
     
  3. 1_deuceracing

    1_deuceracing Member

    Messages:
    88
    Likes Received:
    0
    Joined:
    Jan 28, 2003
    I would try adjusting the valve clearance first like B16 said and see how it goes. After that, run a compression test to see if u might of gotten any bent valves. Get back to us and good luck!!!
     
  4. Dustinr42

    Dustinr42 Junior Member

    Messages:
    16
    Likes Received:
    0
    Joined:
    Mar 8, 2003
    I will try that. Have you guys heard of faulty injectors? It has never made this tick until the timing belt broke.
     
Verification:
Draft saved Draft deleted

Share This Page