1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tonights run in the LST hatch, 100x better but...

Discussion in 'Forced Induction' started by 92civicb18b1, Apr 26, 2005.

  1. 92civicb18b1

    92civicb18b1 The Trisexual

    Messages:
    8,859
    Likes Received:
    18
    Joined:
    Oct 1, 2003
    Location:
    The asshole of the USA, New Jersey
    Well today's run in the LST hatch was 100 times better. No problems whatsoever besides I still have a boost leak. I build about 1-2 psi at 6300 rpm.

    I think I may have sourced the leak and going to attempt to fix it.

    All the paint finally burned off the manifold so I no longer have the annoying smoke. The little oil that was sucked in has burned off also.

    Although everyone said the turbo would fall off after 6500 rpm..I don't think it will and its the only time I'm making boost.

    I'm shifting at 6500 rpm right now, cause I'm making no boost and the stock LS isn't as much fun as it would be with and extra 8 psi of boost.

    At least it's improving. :D
     
  2. 92civicb18b1

    92civicb18b1 The Trisexual

    Messages:
    8,859
    Likes Received:
    18
    Joined:
    Oct 1, 2003
    Location:
    The asshole of the USA, New Jersey
    ppppllllllllllllllllppppppppppp :thumbsdown::thumbsdown::thumbsdown::thumbsdown:
    :thumbsdown::thumbsdown::thumbsdown::thumbsdown:


    SNAPPED THE AXLE AGAIN!!!!!

    I even had a GSR axle this time, I made a second thread, more info on that there.
     
Verification:
Draft saved Draft deleted

Share This Page