1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TPS CEL

Discussion in 'General Tech and Maintenance' started by jastunna1987, Feb 16, 2005.

  1. jastunna1987

    jastunna1987 Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Dec 6, 2003
    i was adjusting my TPS and measuring the voltage one day to see if that contributed to my erratic idle problem. Well anyways, I think i might of accidently broke the tps by dropping it from like 2 inches above the ground. I installed it back in the tb and i've been gettin the CEL 7 (TPS). I got a new one from a friend. I installed it and everything, im still throwing the CEL 7, do i have to adjust or calerbrate it some how. I've tried resetting my ecu by pulling the 7.5a back up fuse & disconnecting the negative battery terminal...i'm still getting it. Any ideas??? Thanks.
     
  2. pills_PMD

    pills_PMD Super Moderator

    Messages:
    4,232
    Likes Received:
    0
    Joined:
    Sep 30, 2002
    Location:
    New Albany, OH
    what voltage did you set the nwe one at??
     
  3. jastunna1987

    jastunna1987 Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Dec 6, 2003
    I havent really had time to set the voltage. Whats happens is that when the TPS is positioned all the way to closed throttle, the idle is at 1500 rpm, and if i increase the position to up the voltage, it will idle at 2000 rpm.

    So right now, the tps is in, but not set correctly. If i do set the voltage at .5v at closed, and 4.5v at wot...will the CEL go away, or do i have to reset the ECU?


     
  4. B16CRX

    B16CRX Senior Member

    Messages:
    531
    Likes Received:
    0
    Joined:
    Jan 24, 2004
    Location:
    Greenville, SC
    you didnt berak your first one. You just need to put it back in teh Trottle body correctly. I had the CEL for a while until I sat there and fixed it. I think I turned it as far to the left as it would go..cant remember

    make sure the voltage is at .5 closed and 4.5 WOT.
     
  5. jastunna1987

    jastunna1987 Member

    Messages:
    87
    Likes Received:
    0
    Joined:
    Dec 6, 2003
    can someone post the exact method used to measure the voltage? I've tried several times, and I dont think im doin it right. Where do you plug the positive lead from the voltmeter to measure the voltage?
     
Verification:
Draft saved Draft deleted

Share This Page